On 23.8.2006, at 13.15, Steen Larsen wrote:

> Hi,
>
> I have been trying out the portlet support in wicket, and have the  
> problem that when I press a button or link it seems like the  
> default "action" is called so that I never sees anything else than  
> the first page. I have tried the portlet example from subversion,  
> and a portlet adapted version of the Navomatic example, both on  
> Jetspeed 2 and BEA Portal, and get the above mentioned behaviour in  
> both portals. Does any one have any experience with this, and maybe  
> a reason why this is happening ?
>

Hi,

Which version of wicket are you using? The portlet support is still  
highly experimental, and there has been great improvements since  
wicket 1.2.1 was relased, so the best choice is the current version  
from the 1.2 branch. Portlet support has not been tested with BEA  
Portal, but several people has been running it successully with  
Jetspeed2.

Can you send me your navomatic sources, so I can make sure it is  
working correctly.

I'm currently working with the unit tests of the wicket portlet support.


Janne




-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Wicket-user mailing list
Wicket-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/wicket-user

Reply via email to