I am not certain if this will work -- worth a try.

Instead of exporting LD_LIBRARY_PATH etc yourself, use the scripts that
Intel provides. These are safer since they keep changing them. For
instance, on my cluster I have

source /opt/intel/composer$VERS/bin/compilervars.sh intel64
source /opt/intel/composer$VERS/mkl/bin/mklvars.sh intel64

# This should work always
export MKLPATH=$MKLROOT/lib/intel64
export MKLINC=$MKLROOT/include

Make sure that you are appropriately compiling, and check what version of
VERS to use

On Wed, Apr 27, 2016 at 9:42 AM, Walid Hetaba <het...@fhi-berlin.mpg.de>

> Dear colleagues,
> I'm trying to get the parallel version of WIEN2k 14.2 running on the
> institute's cluster, but I'm stuck now.
> I searched the mailing list for the error message I receive, but at first
> glance I did not find relevant postings.
> This is the problem I face:
> The serial version of WIEN2k is running fine (also when using qsub and the
> submission system).
> However, when trying to use the parallel version I get the following error
> when lapw1 is invoked in parallel mode:
> "Intel MKL FATAL ERROR: Cannot load symbol MKLMPI_Get_wrappers."
> Here the facts on hard- and software:
> I'm using WIEN2k 14.2 to run the example TiC case from the UG as a test to
> see whether all works out fine.
> I compiled the sofware using the Intel Cluster Studio with the Intel
> Fortran Compiler 16.0, Intel C++ Compiler 16.0, Intel MKL 11.3 and Intel
> MPI.
> I compiled it using FFTW3 and the MKL lapack, scalapack and blacs.
> The cluster consists of 37 nodes with 20 CPUs each. It is running a CentOS
> Linux distribution and it is using SGE as submission system. In the
> submission script orte is used as the parallel environment.
> This is what I've tried so far:
> I don't know why it can't find things from the MKL as I export all my
> environmental variables using the submission script, which I also checked
> by printing them.
> As additional information I include the submission script
> (WIEN2k-test-p.sh, which is still a bit messy as I adopted it from another
> program for testing reasons), the :parallel file with the error messages
> (which I renamed to .parallel so that Thunderbird on Windows can handle
> it), the output-file (TiC.o14540) and the .machines file.
> I get the same error messages when using OpenMPI instead of the IntelMPI,
> but the output is a bit different (see TiC.o14541).
> I did try different ways to export my environmental variables (to get rid
> of unnecessary stuff), also tried mpi as the parallel environment in the
> submission script instead of orte. I also tried to request a different
> number of slots,...
> But nothing off this got me rid of this error message.
> Has anybody experienced a similar problem or are there any hints what else
> I can check?
> Thanks for your help.
> All the best,
> Walid
> --
> Dr.techn. Walid Hetaba
> Fritz-Haber-Institut der Max-Planck-Gesellschaft
> Department of Inorganic Chemistry
> Faradayweg 4-6, 14195 Berlin, Germany
> T: +49 30 8413-4412het...@fhi-berlin.mpg.dehttp://www.fhi-berlin.mpg.de

Professor Laurence Marks
"Research is to see what everybody else has seen, and to think what nobody
else has thought", Albert Szent-Gyorgi
www.numis.northwestern.edu ; Corrosion in 4D: MURI4D.numis.northwestern.edu
Partner of the CFW 100% program for gender equity, www.cfw.org/100-percent
Co-Editor, Acta Cryst A
Wien mailing list

Reply via email to