Don't know if this is the problem here, but very often the problem is the blacks-library. There are several versions of blacks in the mkl and they must be chosen according to your mpi. Of course there is a version for intel-mpi, but it must be the correct library for each mpi.

Am 27.04.2016 um 16:42 schrieb Walid Hetaba:
Dear colleagues,

I'm trying to get the parallel version of WIEN2k 14.2 running on the
institute's cluster, but I'm stuck now.
I searched the mailing list for the error message I receive, but at
first glance I did not find relevant postings.

This is the problem I face:
The serial version of WIEN2k is running fine (also when using qsub and
the submission system).
However, when trying to use the parallel version I get the following
error when lapw1 is invoked in parallel mode:
"Intel MKL FATAL ERROR: Cannot load symbol MKLMPI_Get_wrappers."

Here the facts on hard- and software:
I'm using WIEN2k 14.2 to run the example TiC case from the UG as a test
to see whether all works out fine.
I compiled the sofware using the Intel Cluster Studio with the Intel
Fortran Compiler 16.0, Intel C++ Compiler 16.0, Intel MKL 11.3 and Intel
I compiled it using FFTW3 and the MKL lapack, scalapack and blacs.

The cluster consists of 37 nodes with 20 CPUs each. It is running a
CentOS Linux distribution and it is using SGE as submission system. In
the submission script orte is used as the parallel environment.

This is what I've tried so far:
I don't know why it can't find things from the MKL as I export all my
environmental variables using the submission script, which I also
checked by printing them.
As additional information I include the submission script
(, which is still a bit messy as I adopted it from
another program for testing reasons), the :parallel file with the error
messages (which I renamed to .parallel so that Thunderbird on Windows
can handle it), the output-file (TiC.o14540) and the .machines file.

I get the same error messages when using OpenMPI instead of the
IntelMPI, but the output is a bit different (see TiC.o14541).

I did try different ways to export my environmental variables (to get
rid of unnecessary stuff), also tried mpi as the parallel environment in
the submission script instead of orte. I also tried to request a
different number of slots,...
But nothing off this got me rid of this error message.

Has anybody experienced a similar problem or are there any hints what
else I can check?

Thanks for your help.
All the best,

Dr.techn. Walid Hetaba

Fritz-Haber-Institut der Max-Planck-Gesellschaft
Department of Inorganic Chemistry
Faradayweg 4-6, 14195 Berlin, Germany
T: +49 30 8413-4412

Wien mailing list

Peter BLAHA, Inst.f. Materials Chemistry, TU Vienna, A-1060 Vienna
Phone: +43-1-58801-165300             FAX: +43-1-58801-165982
Email:    WIEN2k:
Wien mailing list

Reply via email to