Dear prof. Blaha,

I tried the new version of lapwso. I replaced mine and recompiled it with no problems, however this did not solve the problem. I'm still getting the same error. It definitely has to do with mpi, because serial version works fine (but takes ages for a single iteration).

During my testing I found that it sometimes happens on second iteration.

I tried different RMTs, more memory, various numbers of cores, nothing helps. My commands are also OK, i have used them numerous times before succesfully, only without the MPI.

Best regards

Maciej Polak

On 07/01/2016 03:02 PM, Peter Blaha wrote:

We had a few problems with lapwso in mpi, so please try this version.

Please report over the mailing list if this new version solved the problem.


On 07/01/2016 11:35 AM, Maciej Polak wrote:
Thank you for your answer and suggestions.

I tried the same calculation with a ridiculous amount of memory (200GB,
while non so calculations finish easily on 10 GB), and a recompiled
lapwso. Nothing changed unfortunately...

I'm lost now, and have no idea how to approach the problem, so I
appreciate any further help.

Best regards

Maciej Polak

On 06/30/2016 10:10 AM, Lyudmila Dobysheva wrote:
29.06.2016 22:07, Maciej Polak wrote:
I'm curious though, how does it get there?

I am not a specialist in commands of shell, but there are several
commands writing their output to .timeso in lapwsopara, for example:
(cd $PWD;$t $exe ${def}_${loop}.def;rm -f .lock_$lockfile[$p])
>>.timeso_$loop &

case.inso looks o'k for me.

ATOM -54: X=0.75880142 Y=0.74505482 Z=0.74909811

Many atoms, without any symmetry operation, the lattice is with angles
of 60 60 60... Maybe this is a reason - not enough memory in computer?
too large arrays?
I'd check this by two ways: decreasing number of atoms, or increasing
size of memory (maybe, recompile lapwso). As far as I remember, lapwso
requires more memory, twice at least, cpmpared to usual lapw1 lapw2.

29.06.2016 12:11, Maciej Polak wrote:
I have trouble with running run_lapw with the "so" switch in parallel.
I narrowed down the origin of this error to be located in .timeso_X
files (.timeso_1).
info in pzheevx16           5 2           1
{    1,    0}:  On entry to
PZUNMTR parameter number    5 had an illegal value
 info in pzheevx16:           5
{    1,    1}:  On entry to
PZSTEIN parameter number    4 had an illegal value

Best wishes
  Lyudmila Dobysheva
Phys.-Techn. Institute of Ural Br. of Russian Ac. of Sci.
426001 Izhevsk, ul.Kirova 132
Tel.:7(3412) 432045(office), 722529(Fax)
E-mail:, (office) (home)
Skype:  lyuka17 (home), lyuka18 (office),english/
Wien mailing list

Wien mailing list

Wien mailing list

Reply via email to