One more thing: is SnSe.r2v_nlvdw empty? If not, until which value of
l (6 or 10) the expansion of v_vdW in SnSe.r2v_nlvdw goes?

On Wednesday 2017-09-13 10:02, Jiawei Zhang wrote:

Date: Wed, 13 Sep 2017 10:02:46
From: Jiawei Zhang <>
Reply-To: A Mailing list for WIEN2k users <>
To: "" <>
Subject: [Wien] Error related to nlvdw calculations

Dear WIEN2k developers and users,
I am trying to do a calculation on some layered materials by including the 
nlvdw correction into SCF calculation in Wien2k 17.1 running at Linux system 
E5-2680, CentOS 7 Linux 64 bit) with intel compilers. The calculations are 
successful without the calculation of the potential; however, I always get 
errors when
I switch on the potential calculations. In the beginning, when I set "calculation of the 
potential (T or F)" to "T" in case.innlvdw, I always get the error
“Insufficient virtual memory”. According to the suggestion from the previous 
post, in the line 41 in SRC_nlvdw/calc_vvdw.F, add : lmtmp =0 and recompile a
selected package : nlvdw. The error “Insufficient virtual memory” is solved. 
But then I always get the following errors:
In case.dayfile,    start (Wed Sep 13 00:35:04 CEST 2017) with nlvdw (200/99 to 
  nlvdw  > & /dev/null (00:35:04) 
  nlvdw (00:36:17) 82.380u 0.204s 1:22.67 99.8% 0+0k 22384+1424io 3pf+0w
    cycle 1 (Wed Sep 13 00:37:40 CEST 2017) (200/99 to go)
  lapw0 -nlvdw (00:37:40) 0.925u 0.063s 0:01.06 92.4% 0+0k 6432+56io 8pf+0w
error: command   /home/jiawei/src/WIEN2k_17.1/lapw0 lapw0.def   failed
  stop error
Error details:
forrtl: severe (64): input conversion error, unit 66, file /home 
Image              PC                Routine            Line        Source
lapw0              000000000051E423  Unknown               Unknown  Unknown
lapw0              000000000054F798  Unknown               Unknown  Unknown
lapw0              000000000054C7EA  Unknown               Unknown  Unknown
lapw0              00000000004444C5  MAIN__                   2102  lapw0.F
lapw0              00000000004054AE  Unknown               Unknown  Unknown          00000039B041ECDD  Unknown               Unknown  Unknown
lapw0              00000000004053B9  Unknown               Unknown  Unknown

For the calculations, I set kpoints=605, RKmax=10, and expand lmax to 10 in 
I have tried running in both single mode or parallel mode and I get the same 
error. Does anyone have any suggestion on how to fix the problem. Thanks in 
Best regards,

Wien mailing list

Reply via email to