https://bugzilla.wikimedia.org/show_bug.cgi?id=73534

            Bug ID: 73534
           Summary: missing language in family causes exception in
                    Page.langlinks
           Product: Pywikibot
           Version: core (2.0)
          Hardware: All
                OS: All
            Status: NEW
          Severity: critical
          Priority: Unprioritized
         Component: General
          Assignee: pywikipedia-b...@lists.wikimedia.org
          Reporter: jay...@gmail.com
       Web browser: ---
   Mobile Platform: ---

On en.wowwiki:

ERROR: testLinks (tests.page_tests.TestPageObject)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "tests/page_tests.py", line 469, in testLinks
    for p in mainpage.langlinks():
  File "pywikibot/page.py", line 1189, in langlinks
    self._langlinks = list(self.iterlanglinks(include_obsolete=True))
  File "pywikibot/site.py", line 2987, in pagelanglinks
    source=self)
  File "pywikibot/page.py", line 4386, in langlinkUnsafe
    link._site = pywikibot.Site(lang, source.family.name)
  File "pywikibot/__init__.py", line 573, in Site
    _sites[key] = interface(code=code, fam=fam, user=user, sysop=sysop)
  File "pywikibot/site.py", line 1422, in __init__
    BaseSite.__init__(self, code, fam, user, sysop)
  File "pywikibot/site.py", line 451, in __init__
    % (self.__code, self.__family.name))
UnknownSite: Language nn does not exist in family wowwiki

-- 
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to