I think you've got some things mixed up.

When you tried installing a CPAN.org module in an Active State PERL distro, it 
didn't work. In my experience, Active State's perl does not work reliably with 
CPAN modules.  So, a failed cpan module install in an Active State distro is no 
surprise to me.

What you needed to do was remove Active State's PERL distro and double check 
Active State cleared all their environment variables and reboot before 
installing Strawberry Perl.

I ran install Win32::DirSize in cpan on one of my windows 2003 servers with no 
problems.  It seems the package is light on tests (none) and doesn't include a 
Makefile.PL.  It installed fine.

On Wednesday, March 12, 2014 9:08 AM, CARL Hurley <carl.hur...@email.edcc.edu> 
I'm looking for someone to confirm that I can install and run this pm on this 

I have installed Strawberry Perl 5.14 and installed this pm.  The program code 
that ran fine on MS Win Server 2000 and Active States Perl 5.8 gave me an error 
when attempting to load the module.

I removed Strawberry Perl.

I have also attempted to install DWimPerl and install this pm on it and run my 
script.  That did not work either.

I'm doing something wrong.  I may have tried too many things at this point and 
not backed everything out correctly when trying something NEW.

At the present time the server only has DWimPerl installed.

I have a directory located at 
\DWIMPERL\CPAN\BUILD\Win32-DirSize-1.13-JNinsi\Win32\DirSize AND  

This does not seem correct to me.  I'm thinking I need to use the uninstaller 
to remove DWimPerl and any remanents of the first install of Strawberry Perl as 
well as all the remaining traces of Win32::DirSize and try installing this all 
over again.

If someone knows that this pm will not run on this version of Windows Server 
then I will know not to keep beating my head against this wall.

I have a file with notes related to my attempts to install this pm that I will 
provide if we know the install should work and need some additional background 
to determine what went wrong.



Reply via email to