You might look into UDEV rules... and setting up aliases for each device
based on its identifiers. I've got a similar thing going on with a
RigBlaster and another USB audio device... The Serial control lines were
getting mixed up until I set the RB to always come up as /dev/ttyUSB-RB and
the serial GPIO on the USB soundcard to /dev/ttyUSB-SCGP... These survive
reboots because they're set in the UDEV rules. (this is all complicated by
the addition of an Edgeport-8, so there are at any one time, at least 10
usb-serial devices plugged into this machine at one time.)
Whenever I reboot, the RB still comes up as /dev/ttyUSB-RB, etc.. so I
don't need to hope that /dev/ttyUSB0 always is the RigBlaster and
/dev/ttyUSB9 is the serial GPIO...
It might help, it might not, but it's worth looking into.

At least it works on Linux.

73 de AI8W, Chris

On Wed, Feb 12, 2020 at 6:12 PM ALLAN LOVETT via wsjt-devel <
wsjt-devel@lists.sourceforge.net> wrote:

> The thing that drives me crazy it that it seems that everytime I turn
> everything on, the USB inputs and outputs have changed names. At least for
> the Audio,  you can take care of this by opening Audio MIDI Setup and
> reagent aggregate Devices. I made an IC7300 out and in and a IC9700 Out and
> In. You can do this by only connecting one radio at a time, so it is easier
> to tell which one you are working with. Once it is set up, it is easy to
> make sure that you are connecting the correct Audio to the software.
>
> Allan
> N7RP
>
> > On Feb 12, 2020, at 7:50 AM, Steven Nash <stevengn...@gmail.com> wrote:
> >
> > Hi,
> >
> > I have both the Icom IC-7300 and IC-9700 working with MacLoggerDX on
> MacOS 10.14, providing both rigs are not connected via USB at the same time.
> >
> > When both are connected at the same time then WSJT-X always tries to
> send/receive via the 7300 (even if the 7300 is switched off and 9700 is
> on).  Changing audio device for input/output in WSJT-X makes no
> difference.  Rig operation via MacLoggerDX controls the correctly selected
> rig in MacLoggerDX.  It is only USB audio that is the issue.
> >
> > 73
> > Steve G0UQT
> > _______________________________________________
> > wsjt-devel mailing list
> > wsjt-devel@lists.sourceforge.net
> > https://lists.sourceforge.net/lists/listinfo/wsjt-devel
>
>
>
> _______________________________________________
> wsjt-devel mailing list
> wsjt-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/wsjt-devel
>
_______________________________________________
wsjt-devel mailing list
wsjt-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/wsjt-devel

Reply via email to