thanks for your quick help, Atze.

> this problem is fixed in the forked repo
> https://github.com/atzedijkstra/wxHaskell. See the README there. The
> intent is that this fork will merge back into the official repo and
> an update of the version available via cabal and Hackage.

I have installed wxWidgets 2.9.5 in ~/local. When I run bin/mk-cabal
inside the local checkout of the repository
https://github.com/wxHaskell/wxHaskell (as I understood from your
other e-mail), the following build failure is triggered:

    generated 1488 methods for 124 classes.
    generating: src/haskell/Graphics/UI/WXCore/WxcClassesMZ.hs
    generated 2340 methods for 129 classes.
    generating: src/haskell/Graphics/UI/WXCore/WxcClasses.hs
    generated 3828 total methods for 253 total classes.
    setup: Missing dependency on a foreign library:
    * Missing C library: wxc
    This problem can usually be solved by installing the system package that
    provides this library (you may need the "-dev" version). If the library is
    already installed but in a non-standard location then you can use the flags
    --extra-include-dirs= and --extra-lib-dirs= to specify where it is.
    cabal: Error: some packages failed to install:
    wxcore- failed during the configure step. The exception was:
    ExitFailure 1
    Resolving dependencies...
    Configuring wx-
    cabal: At least the following dependencies are missing:
    wxcore >=
    Resolving dependencies...
    cabal: Could not resolve dependencies:

I have ghc 7.4.1 and haskell-platform 2012.2.0.0.
Any help appreciated. :)


Get your SQL database under version control now!
Version control is standard for application code, but databases havent 
caught up. So what steps can you take to put your SQL databases under 
version control? Why should you start doing it? Read more to find out.
wxhaskell-devel mailing list

Reply via email to