See 
<http://jenkins.x2go.org:8080/job/pyhoca-cli+nightly+opensuse-tumbleweed/2/display/redirect?page=changes>

Changes:

[mike.gabriel] Enforce Python3 build, fix FTBFS. (debian/rules: Switch to 
pybuild DH

------------------------------------------
[...truncated 54.41 KB...]
[   52s] [114/131] cumulate dwz-0.12-3.11
[   52s] [115/131] cumulate cracklib-2.9.6-2.1
[   52s] [116/131] cumulate libebl-plugins-0.168-7.1
[   52s] [117/131] cumulate libdw1-0.168-7.1
[   52s] [118/131] cumulate pam-1.3.0-6.5
[   52s] [119/131] cumulate shadow-4.5-8.1
[   52s] [120/131] cumulate rpm-4.14.1-2.1
[   52s] [121/131] cumulate sysuser-shadow-2.0-2.4
[   52s] [122/131] cumulate rpmlint-mini-1.10-5.6
[   52s] [123/131] cumulate build-compare-20171204T112209.f06fbac-1.2
[   52s] [124/131] cumulate rpmlint-Factory-1.0-92.1
[   52s] [125/131] cumulate system-group-hardware-20170617-5.4
[   52s] [126/131] cumulate libutempter0-1.1.6-10.1
[   52s] [127/131] cumulate util-linux-2.31.1-2.1
[   53s] [128/131] cumulate aaa_base-84.87+git20180208.8eeab90-1.1
[   53s] [129/131] cumulate rpm-build-4.14.1-2.1
[   53s] [130/131] cumulate aaa_base-malloccheck-84.87+git20180208.8eeab90-1.1
[   53s] [131/131] cumulate post-build-checks-84.87+git20171221.9eed556-1.1
[   53s] now installing cumulated packages
[   53s] Preparing...                          
########################################
[   53s] Updating / installing...
[   53s] system-user-root-20170617-1.8         
########################################
[   53s] filesystem-15.5-22.1                  
########################################
[   53s] glibc-2.27-1.1                        
########################################
[   53s] libz1-1.2.11-3.9                      
########################################
[   54s] libgcc_s1-7.3.1+r258025-1.2           
########################################
[   54s] perl-base-5.26.1-4.1                  
########################################
[   54s] libbz2-1-1.0.6-40.4                   
########################################
[   54s] libgmp10-6.1.2-2.11                   
########################################
[   54s] libstdc++6-7.3.1+r258025-1.2          
########################################
[   54s] liblzma5-5.2.3-4.7                    
########################################
[   54s] libattr1-2.4.47-7.113                 
########################################
[   54s] libacl1-2.2.52-13.6                   
########################################
[   55s] libaudit1-2.8.1-2.1                   
########################################
[   55s] libxml2-2-2.9.7-1.2                   
########################################
[   55s] libmpfr6-4.0.1-1.1                    
########################################
[   55s] fillup-1.42-274.1                     
########################################
[   55s] libcap2-2.25-4.1                      
########################################
[   55s] libpcre1-8.41-3.4                     
########################################
[   55s] libselinux1-2.6-1.4                   
########################################
[   55s] libpython3_6m1_0-3.6.4-5.1            
########################################
[   55s] libuuid1-2.31.1-2.1                   
########################################
[   55s] libblkid1-2.31.1-2.1                  
########################################
[   55s] libmpc3-1.1.0-1.1                     
########################################
[   55s] libelf1-0.168-7.1                     
########################################
[   55s] libdw1-0.168-7.1                      
########################################
[   55s] libebl-plugins-0.168-7.1              
########################################
[   55s] libisl15-0.18-2.1                     
########################################
[   56s] cpp7-7.3.1+r258025-1.2                
########################################
[   56s] libexpat1-2.2.5-1.1                   
########################################
[   56s] libgomp1-7.3.1+r258025-1.2            
########################################
[   56s] libpopt0-1.16-29.5                    
########################################
[   56s] dwz-0.12-3.11                         
########################################
[   56s] libfdisk1-2.31.1-2.1                  
########################################
[   56s] libmount1-2.31.1-2.1                  
########################################
[   56s] tar-1.29-5.6                          
########################################
[   56s] libglib-2_0-0-2.54.3-1.1              
########################################
[   56s] libcroco-0_6-3-0.6.12-3.3             
########################################
[   56s] libcilkrts5-7.3.1+r258025-1.2         
########################################
[   56s] libdb-4_8-4.8.30-34.1                 
########################################
[   56s] libubsan0-7.3.1+r258025-1.2           
########################################
[   57s] libasan4-7.3.1+r258025-1.2            
########################################
[   57s] liblsan0-7.3.1+r258025-1.2            
########################################
[   57s] libtsan0-7.3.1+r258025-1.2            
########################################
[   57s] libopenssl1_1-1.1.0g-1.1              
########################################
[   57s] libatomic1-7.3.1+r258025-1.2          
########################################
[   57s] libcap-ng0-0.7.9-1.1                  
########################################
[   57s] libcom_err2-1.43.8-2.1                
########################################
[   57s] libffi7-3.2.1.git259-5.1              
########################################
[   57s] libgdbm4-1.12-1.31                    
########################################
[   61s] perl-5.26.1-4.1                       
########################################
[   62s] libitm1-7.3.1+r258025-1.2             
########################################
[   62s] libkeyutils1-1.5.10-2.4               
########################################
[   62s] liblua5_3-5-5.3.4-1.5                 
########################################
[   62s] libmpx2-7.3.1+r258025-1.2             
########################################
[   62s] libmpxwrappers2-7.3.1+r258025-1.2     
########################################
[   62s] libsepol1-2.6-1.4                     
########################################
[   62s] libsmartcols1-2.31.1-2.1              
########################################
[   62s] libsqlite3-0-3.22.0-1.1               
########################################
[   63s] libustr-1_0-1-1.0.4-34.112            
########################################
[   63s] libsemanage1-2.6-1.4                  
########################################
[   63s] libverto1-0.2.6-6.4                   
########################################
[   63s] krb5-1.15.2-4.2                       
########################################
[   63s] patch-2.7.5-1.121                     
########################################
[   63s] pkg-config-0.29.2-1.10                
########################################
[   64s] terminfo-base-6.1-2.1                 
########################################
[   64s] libncurses6-6.1-2.1                   
########################################
[   64s] libreadline7-7.0-102.1                
########################################
[   64s] bash-4.4-102.1                        
########################################
[   65s] coreutils-8.29-2.1                    
########################################
[   65s] grep-3.1-2.1                          
########################################
[   65s] cpio-2.12-4.10                        
########################################
[   65s] diffutils-3.6-2.1                     
########################################
[   65s] permissions-20180125-1.1              
########################################
[   65s] Updating /etc/sysconfig/security ...
[   68s] Warning: running kernel does not support fscaps
[   68s] Checking permissions and ownerships - using the permissions files
[   68s]        /etc/permissions
[   68s]        /etc/permissions.easy
[   68s]        /etc/permissions.local
[   68s] setting /dev/full to root:root 0666. (wrong permissions 0622)
[   68s] setting /sbin/unix_chkpwd to root:shadow 4755. (wrong owner/group 
root:root)
[   68s] setting /sbin/unix2_chkpwd to root:shadow 4755. (wrong owner/group 
root:root)
[   68s] sed-4.4-1.4                           
########################################
[   68s] update-alternatives-1.19.0.4-2.1      
########################################
[   68s] gawk-4.2.1-1.2                        
########################################
[   69s] update-alternatives: using /usr/bin/gawk to provide /bin/awk (awk) in 
auto mode
[   70s] binutils-2.29.1-5.1                   
########################################
[   70s] update-alternatives: using /usr/bin/ld.bfd to provide /usr/bin/ld (ld) 
in auto mode
[   70s] findutils-4.6.0-3.1                   
########################################
[   70s] systemd-rpm-macros-3-13.1             
########################################
[   71s] linux-glibc-devel-4.15-1.1            
########################################
[   71s] glibc-devel-2.27-1.1                  
########################################
[   78s] gcc7-7.3.1+r258025-1.2                
########################################
[   80s] glibc-locale-2.27-1.1                 
########################################
[   80s] cpp-7-2.9                             
########################################
[   80s] gcc-7-2.9                             
########################################
[   80s] gzip-1.9-1.1                          
########################################
[   81s] make-4.2.1-5.1                        
########################################
[   81s] which-2.21-3.15                       
########################################
[   81s] bzip2-1.0.6-40.4                      
########################################
[   81s] xz-5.2.3-4.7                          
########################################
[   81s] gettext-runtime-0.19.8.1-5.3          
########################################
[   81s] gettext-tools-0.19.8.1-5.3            
########################################
[   81s] libcrack2-2.9.6-2.1                   
########################################
[   81s] cracklib-2.9.6-2.1                    
########################################
[   81s] ncurses-utils-6.1-2.1                 
########################################
[   81s] 
python-rpm-macros-2017.12.22.d9968ab-1########################################
[   81s] libtirpc-netconfig-1.0.2-2.1          
########################################
[   81s] libtirpc3-1.0.2-2.1                   
########################################
[   81s] libnsl2-1.2.0-2.1                     
########################################
[   82s] python3-base-3.6.4-5.1                
########################################
[   82s] python3-six-1.11.0-2.2                
########################################
[   82s] pam-1.3.0-6.5                         
########################################
[   82s] Warning: running kernel does not support fscaps
[   82s] Warning: running kernel does not support fscaps
[   82s] shadow-4.5-8.1                        
########################################
[   82s] Warning: running kernel does not support fscaps
[   82s] Warning: running kernel does not support fscaps
[   82s] Warning: running kernel does not support fscaps
[   82s] Warning: running kernel does not support fscaps
[   82s] Warning: running kernel does not support fscaps
[   82s] Warning: running kernel does not support fscaps
[   82s] Warning: running kernel does not support fscaps
[   82s] Warning: running kernel does not support fscaps
[   82s] Warning: running kernel does not support fscaps
[   82s] sysuser-shadow-2.0-2.4                
########################################
[   82s] groupadd -r kmem
[   83s] groupadd -r lock
[   83s] groupadd -r -g 5 tty
[   83s] groupadd -r utmp
[   85s] groupadd -r audio
[   85s] groupadd -r cdrom
[   85s] groupadd -r dialout
[   85s] groupadd -r disk
[   86s] groupadd -r input
[   86s] groupadd -r kvm
[   86s] groupadd -r lp
[   86s] groupadd -r tape
[   86s] groupadd -r video
[   86s] system-group-hardware-20170617-5.4    
########################################
[   86s] libutempter0-1.1.6-10.1               
########################################
[   86s] Warning: running kernel does not support fscaps
[   86s] util-linux-2.31.1-2.1                 
########################################
[   86s] Warning: running kernel does not support fscaps
[   86s] setting /usr/bin/wall to root:tty 2755. (wrong permissions 0755)
[   86s] setting /usr/bin/write to root:tty 2755. (wrong permissions 0755)
[   86s] Warning: running kernel does not support fscaps
[   86s] 
aaa_base-84.87+git20180208.8eeab90-1.1########################################
[   86s] Updating /etc/sysconfig/language ...
[   86s] Updating /etc/sysconfig/proxy ...
[   86s] Updating /etc/sysconfig/windowmanager ...
[   87s] 
aaa_base-malloccheck-84.87+git20180208########################################
[   87s] python3-appdirs-1.4.3-1.3             
########################################
[   87s] python3-pyparsing-2.2.0-1.3           
########################################
[   87s] python3-packaging-16.8-3.3            
########################################
[   87s] python3-3.6.4-5.1                     
########################################
[   87s] file-magic-5.32-4.1                   
########################################
[   87s] libmagic1-5.32-4.1                    
########################################
[   87s] rpm-4.14.1-2.1                        
########################################
[   87s] Updating /etc/sysconfig/services ...
[   87s] file-5.32-4.1                         
########################################
[   87s] rpmlint-mini-1.10-5.6                 
########################################
[   87s] rpmlint-Factory-1.0-92.1              
########################################
[   87s] 
build-compare-20171204T112209.f06fbac-########################################
[   87s] rpm-build-4.14.1-2.1                  
########################################
[   88s] python3-setuptools-38.5.1-2.1         
########################################
[   88s] update-alternatives: using /usr/bin/easy_install-3.6 to provide 
/usr/bin/easy_install (easy_install) in auto mode
[   88s] 
post-build-checks-84.87+git20171221.9e########################################
[   88s] python3-devel-3.6.4-5.1               
########################################
[   88s] gcc-PIE-7-2.9                         
########################################
[   88s] 
brp-check-suse-84.87+git20170602.cec54########################################
[   88s] attr-2.4.47-7.113                     
########################################
[   88s] brp-extract-appdata-2016.05.04-1.4    
########################################
[   88s] build-mkbaselibs-20180209-1.1         
########################################
[   88s] fdupes-1.61-1.10                      
########################################
[   88s] hostname-3.20-1.1                     
########################################
[   89s] removing nis flags from 
/var/cache/obs-build/opensuse/tumbleweed/x86_64/etc/nsswitch.conf...
[   89s] now finalizing build dir...
[   90s] -----------------------------------------------------------------
[   90s] ----- building pyhoca-cli.spec (user abuild)
[   90s] -----------------------------------------------------------------
[   90s] -----------------------------------------------------------------
[   90s] + exec rpmbuild --define '%vendor X2Go' -bb --define '_srcdefattr 
(-,root,root)' --nosignature --define '_build_create_debug 1' 
/home/abuild/rpmbuild/SOURCES/pyhoca-cli.spec
[   90s] Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.t6Ey1C
[   90s] + umask 022
[   90s] + cd /home/abuild/rpmbuild/BUILD
[   90s] + cd /home/abuild/rpmbuild/BUILD
[   90s] + rm -rf pyhoca-cli-0.5.99.0
[   90s] + /usr/bin/gzip -dc 
/home/abuild/rpmbuild/SOURCES/pyhoca-cli-0.5.99.0.tar.gz
[   90s] + /usr/bin/tar -xof -
[   90s] + STATUS=0
[   90s] + '[' 0 -ne 0 ']'
[   90s] + cd pyhoca-cli-0.5.99.0
[   90s] + /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
[   90s] + exit 0
[   90s] Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.fdVBOx
[   90s] + umask 022
[   90s] + cd /home/abuild/rpmbuild/BUILD
[   90s] + /usr/bin/rm -rf 
/home/abuild/rpmbuild/BUILDROOT/pyhoca-cli-0.5.99.0-0.0x2go1.0.git20180306.245.heuler.x86_64
[   90s] ++ dirname 
/home/abuild/rpmbuild/BUILDROOT/pyhoca-cli-0.5.99.0-0.0x2go1.0.git20180306.245.heuler.x86_64
[   90s] + /usr/bin/mkdir -p /home/abuild/rpmbuild/BUILDROOT
[   90s] + /usr/bin/mkdir 
/home/abuild/rpmbuild/BUILDROOT/pyhoca-cli-0.5.99.0-0.0x2go1.0.git20180306.245.heuler.x86_64
[   90s] + cd pyhoca-cli-0.5.99.0
[   90s] + /usr/bin/python3 setup.py build
[   90s] Traceback (most recent call last):
[   90s]   File "setup.py", line 26, in <module>
[   90s]     for line in open(os.path.join('x2go', 
'__init__.py'),encoding='utf-8').readlines():
[   90s] FileNotFoundError: [Errno 2] No such file or directory: 
'x2go/__init__.py'
[   90s] error: Bad exit status from /var/tmp/rpm-tmp.fdVBOx (%build)
[   90s] 
[   90s] 
[   90s] RPM build errors:
[   90s]     Bad exit status from /var/tmp/rpm-tmp.fdVBOx (%build)
[   90s] 
[   90s] japsand failed "build pyhoca-cli.spec" at Tue Mar  6 20:11:02 UTC 2018.
[   90s] 
+ exit 1
+ cleanup
+ '[' -n '' ']'
+ '[' -n '' ']'
+ echo 'Warning: mock temporary config directory not defined. Skipping cleanup.'
Warning: mock temporary config directory not defined. Skipping cleanup.
+ typeset temp_dir=
+ for temp_dir in "${temp_cleanup[@]}"
+ '[' -n /var/lib/jenkins/tmp/tmp.dAP4wncG8fkmYUfjwOVod567 ']'
+ '[' -d /var/lib/jenkins/tmp/tmp.dAP4wncG8fkmYUfjwOVod567 ']'
+ rm -Rf -- /var/lib/jenkins/tmp/tmp.dAP4wncG8fkmYUfjwOVod567
Build step 'Execute shell' marked build as failure
_______________________________________________
x2go-commits mailing list
x2go-commits@lists.x2go.org
https://lists.x2go.org/listinfo/x2go-commits

Reply via email to