This is my main system, where I use X2goserver every day of the week and
have done so for years, it worked really well for many years now.
After doing the newest x2goserver update, several things broke and I can't
install x2go anymore. So I decided to clean up any old install, purged
everything. Purge complained that directories were not empty. Then, after I
erased the directories, it complains that they are not there (apt is super
annoying at times where you can't get it right, no matter how you try). Now
I'm stuck, can't install or deinstall:

When installing, I get:
X2Go is configured to use a non-SQLite DB backend, leaving the database
alone

(who configure that? I definitely not. There should not be a piece of x2go
configuration left on the system, the whole point of the purge)

Then the installer fails, because it probably does not have any db to work
with?
---------------------------------------------------------------------------
Created symlink
/etc/systemd/system/multi-user.target.wants/x2goserver.service →
/lib/systemd/system/x2goserver.service.
Job for x2goserver.service failed because the control process exited with
error code.
See "systemctl status x2goserver.service" and "journalctl -xe" for details.
invoke-rc.d: initscript x2goserver, action "start" failed.
● x2goserver.service - X2Go Server Daemon
   Loaded: loaded (/lib/systemd/system/x2goserver.service; enabled; vendor
preset: enabled)
   Active: failed (Result: exit-code) since Mon 2018-03-12 17:47:07 PDT;
7ms ago
  Process: 27309 ExecStart=/usr/sbin/x2gocleansessions (code=exited,
status=255)
---------------------------------------------------------------------------------
Now I still can't purge the config, when it complains that it has no
directory to rm, I create the dir, yet it erases it, then complains that it
is not there, which is the oddest thing ever:

# apt purge x2goserver
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer
required:
  libjlha-java libx2go-log-perl libx2go-server-db-perl libx2go-server-perl
libxcompshad3
  linux-headers-4.9.0-4-amd64 linux-headers-4.9.0-4-common
linux-headers-4.9.0-5-amd64
  linux-headers-4.9.0-5-common nxagent x2goserver-common
x2goserver-x2goagent
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  x2goserver* x2goserver-extensions* x2goserver-fmbindings*
x2goserver-printing* x2goserver-xsession*
0 upgraded, 0 newly installed, 5 to remove and 2 not upgraded.
5 not fully installed or removed.
After this operation, 730 kB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 660010 files and directories currently installed.)
Removing x2goserver-xsession (4.1.0.0-0x2go1.2+git20180302.1517+9.main.1)
...
Removing x2goserver-printing (4.1.0.0-0x2go1.2+git20180302.1517+9.main.1)
...
Removing x2goserver-extensions (4.1.0.0-0x2go1.2+git20180302.1517+9.main.1)
...
Removing x2goserver-fmbindings (4.1.0.0-0x2go1.2+git20180302.1517+9.main.1)
...
Error in file "/usr/share/applications/evince.desktop": "" is an invalid
MIME type ("" does not contain a subtype)
Removing x2goserver (4.1.0.0-0x2go1.2+git20180302.1517+9.main.1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for doc-base (0.10.7) ...
Processing 4 removed doc-base files, 2 added doc-base files...
Error while merging /usr/share/doc-base/kino-en with
/usr/share/doc-base/kino-fr: format html already defined.
Registering documents with scrollkeeper...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for shared-mime-info (1.8-1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Processing triggers for gnome-menus (3.13.3-9) ...
(Reading database ... 659820 files and directories currently installed.)
Purging configuration files for x2goserver-printing
(4.1.0.0-0x2go1.2+git20180302.1517+9.main.1) ...
Purging configuration files for x2goserver-xsession
(4.1.0.0-0x2go1.2+git20180302.1517+9.main.1) ...
Purging configuration files for x2goserver-fmbindings
(4.1.0.0-0x2go1.2+git20180302.1517+9.main.1) ...
Error in file "/usr/share/applications/evince.desktop": "" is an invalid
MIME type ("" does not contain a subtype)
Purging configuration files for x2goserver
(4.1.0.0-0x2go1.2+git20180302.1517+9.main.1) ...
rmdir: failed to remove '/etc/x2go': No such file or directory
dpkg: error processing package x2goserver (--purge):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 x2goserver
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)
------------------------------------------------------------------------------------------------
so I create /etc/x2go
mkdir /etc/x2go

execute purge again and get the same error:


Purging configuration files for x2goserver
(4.1.0.0-0x2go1.2+git20180302.1517+9.main.1) ...
rmdir: failed to remove '/etc/x2go': No such file or directory

# ls /etc/x2go
ls: cannot access '/etc/x2go': No such file or directory

-------------------------------------------------------------
But anyway, even when all config is removed from the system, I still can't
install it, I still get the configuration message for the db.

-- 
*Por sperto kaj lerno ne sufiĉas eterno.*
_______________________________________________
x2go-user mailing list
x2go-user@lists.x2go.org
https://lists.x2go.org/listinfo/x2go-user

Reply via email to