On Fri, Aug 4, 2017 at 2:53 PM, Wei Liu <wei.l...@citrix.com> wrote:
> On Wed, Aug 02, 2017 at 02:37:10PM +0300, Oleksandr Grytsov wrote:
>> >> >> From other side this rename touches only internals changes: no changes
>> >> >> in config file
>> >> >> or CLI interface.
>> >> >>
>> >> >
>> >> > As said, the framework need to be ready to deal with PCI anyway.
>> >> >
>> >> > What sort of issues do you foresee here?
>> >> Do you mean in case to rework PCI to use the device framework?
>> > No, I mean adding the new hook. You said "handle irregular device name
>> > looks not so good"
>> As for me when only internal name of structure or fields are changed
>> then it should not break anyone configs, setup etc.
>> Creating hooks in this case makes code hard to read and maintain.
> I think you missed my points:
> 1. libxl types generated from libxl_types.idl aren't just used by xl.
> Some applications will use libxl types directly. Not breaking xl config
> doesn't mean not breaking other toolstacks like libvirt. In this
> particular case, I think we might be able to change p9 to p9s because it
> is only released a few months back because the only other known
> toolstack that uses libxl can't possibly use that field at the moment.
> But Ian might disagree.
I got it. I think that we have to change p9 to p9s ASAP to avoid future hooks.
> 2. There is another type, pci dev, that has been there since forever. We
> need a hook to deal with it, we can't rename it.
For PCI all hooks are already there (DEFINE_DEVICE_TYPE_STRUCT_X
to handle pcidev and pci). Also I didn't change PCI fields, names etc.
In libxl_domain_config it is already pcidevs. So, we are safe with PCI.
Sorry I don't understand your concern about PCI. Or I miss something?
> 1 and 2 are orthogonal. 2 is a hard requirement.
Xen-devel mailing list