Andrew Cooper writes ("Re: [PATCH] build: Rename as-insn-check to as-insn-add"):
> Ok - how do we unblock this?
> There appears to be agreement that as-insn-check isn't a great name, and
> my proposed as-insn-add isn't much better.
> The base runes of as-insn and cc-option are compatible. They check the
> fragment, and yield one of two options. cc-option-add and as-insn-check
> are built on top of the base runes, and mutate the flags passed in.
> as-check-frag-update-option ?
My preferred bikeshed colour is `as-insn-add'. I agree that simply
`check' is wrong but would be content with almost anything else.
Xen-devel mailing list