On Thu, 2006-08-24 at 10:42 -0400, Kiyokuni Kawachiya wrote:

> Today, I installed necessary tools including mercurial to LinuxPPC,
> self-built XenPPC, dom0 Linux, and Xen Tools on LinuxPPC, and installed
> them.  I also built j9-xen-ppc with the latest codes, and tried to start it
> on my Linux/XenPPC/JS20.  The xend daemon was successfully started, but
> when I tried "xm create -c xen-domain-config", it failed with the following
> message.
>     Error: [Errno 2] No such file or directory:
> '/proc/device-tree/cpus/PowerPC,[EMAIL PROTECTED]'
> The directory does not exist in my dom0 Linux, but "PowerPC,[EMAIL 
> PROTECTED]" exists
> instead.  Maybe, my JS20 is newer than Watson's, and uses different CPU
> (970FX).  Today, I have no time to debug this further.  Any solution?

Sigh. For the moment you can use this patch:

diff -r b2f2c477895a tools/python/xen/xend/FlatDeviceTree.py
--- a/tools/python/xen/xend/FlatDeviceTree.py   Tue Aug 22 16:48:58 2006 -0500
+++ b/tools/python/xen/xend/FlatDeviceTree.py   Thu Aug 24 10:30:32 2006 -0500
@@ -295,8 +295,8 @@ def build(imghandler):
     def _nolinuxprops(fullpath):
         return not os.path.basename(fullpath).startswith('linux,')
     for i in range(imghandler.vm.getVCpuCount()):
-        cpu = cpus.addnode('PowerPC,[EMAIL PROTECTED]')
-        _copytree(cpu, 'cpus/PowerPC,[EMAIL PROTECTED]', _nolinuxprops)
+        cpu = cpus.addnode('PowerPC,[EMAIL PROTECTED]')
+        _copytree(cpu, 'cpus/PowerPC,[EMAIL PROTECTED]', _nolinuxprops)
         # and then overwrite what we need to
         pft_size = imghandler.vm.info.get('pft-size', 0x14)
         cpu.setprop('ibm,pft-size', 0, pft_size)

I'll try to come up with a more general solution.

Hollis Blanchard
IBM Linux Technology Center

Xen-ppc-devel mailing list

Reply via email to