Just as a heads up, there seem to be a couple of issues with grubby and
the grub.cfg submenus used for Xen right now. My system still boots
after triggering any of these but it's usually not running Xen and not
always running the kernel I want it to be running.

Kernel submenu entries aren't updated w/ kernel updates:
 - https://bugzilla.redhat.com/show_bug.cgi?id=748551
 This can be worked around by regenerating grub.cfg @ every kernel
 update ('grub2-mkconfig -o /boot/grub2/grub.cfg')

There are a couple other grubby issues that I haven't hit naturally yet
(not difficult to provoke, though). Both can be worked around by
regenerating grub.cfg after making kernel changes but before rebooting.

 - Extra entries are being removed from grub.cfg @ kernel pkg removal
   * https://bugzilla.redhat.com/show_bug.cgi?id=744717
   * I haven't personally seen this during kernel removal @ upgrade time
     but it's something to watch out for if you are removing kernels

 - Whitespace is removed from grub default once grub.cfg is processed
   by grubby. 
   * https://bugzilla.redhat.com/show_bug.cgi?id=742720
   * 748551 also stomps on the default in grub.cfg, so I haven't seen
     this yet but it could show up.

Attachment: signature.asc
Description: PGP signature

xen mailing list

Reply via email to