Hi, folks,

I've got two problems with grub2 that I thought others might have solved 
already.   My initial attempts haven't been fruitful.

I have an f20 Dom0.  

Problem #1

My /etc/default/grub looks like [1].  

I try to set the Dom0 to boot with:

  grub2-set-default 'Fedora, with Xen 4.3.2 and Linux 3.12.10-300.fc20.x86_64'

and the default non-Xen menuentry gets booted instead.

It's definitely there in the config file [2] and I can boot it manually.  I 
really need the machine to be able to boot unattended.  I tried setting it 
manually in /etc/grub/default but that doesn't work either.

I'm generating the grub.cfg with grub2-mkconfig > /boot/grub2/grub.cfg and have 
re-installed grub2 on my /dev/sda and /dev/sdb (raid-1 /boot).

Problem #2

When I try to boot from grub manually, I first get an error message saying 
"xen_rm_opts" unknown command.  In each Xen menuentry, I see, e.g.:

        echo    'Loading Xen xen ...'
        if [ "$grub_platform" = "pc" -o "$grub_platform" = "" ]; then
            xen_rm_opts="no-real-mode edd=off"

whereas in previous times I remember the first conditional block saying:


I presume that makes the difference between a statement and an assignment in 
whatever sh-ish language grub is using.  I'm not sure where to fix that as I'm 
no grub2 expert.  I kinda miss the simplicity of 'default=6'. :)

My third possible-grub problem relates to memory and I'm not sure it really is 
a problem in grub2 yet, so I'll post that separately.

Thanks in advance!


GRUB_CMDLINE_LINUX="root=LABEL=librescu-root rootflags=data=journal rd_NO_LUKS 
rd.md=auto rd.lvm=0 rd.dm=0 KEYTABLE=us SYSFONT=lata
rcyrheb-sun16 rd.luks=0 LANG=en_US.UTF-8 selinux=0 elevator=deadline mem=4096M 
max_loop=32 selinux=0 ipv6.disable=1"
GRUB_CMDLINE_XEN="dom0_max_vcpus=2 dom0_vcpus_pin dom0_mem=4096M,max:4096M"
GRUB_SERIAL_COMMAND="serial --unit=0 --speed=19200 --word=8 --parity=no 
GRUB_TERMINAL="serial console"


# grep "'Fedora, with Xen 4.3.2 and Linux 3.12.10-300.fc20.x86_64'" 
                menuentry 'Fedora, with Xen 4.3.2 and Linux 
3.12.10-300.fc20.x86_64' --class fedora --class gnu-linux --class gnu --class 
os --class xen $menuentry_id_option 

Bill McGonigle, Owner   
BFC Computing, LLC       
Telephone: +1.855.SW.LIBRE
Email, IM, VOIP: b...@bfccomputing.com           
VCard: http://bfccomputing.com/vcard/bill.vcf
Social networks: bill_mcgonigle/bill.mcgonigle
xen mailing list

Reply via email to