rustc (1.17.0+dfsg2-8~ubuntu0.16.04.2) xenial; urgency=medium

  * Backport 1.17.0 to xenial
  * Relax llvm-toolchain-3.9 requirement to 1:3.9.1-4~
  * Relax the gdb requirement and don't build-conflict on gdb-minimal

rustc (1.17.0+dfsg2-8) unstable; urgency=medium

  * Workaround for linux #865549, fix FTBFS on ppc64el.

rustc (1.17.0+dfsg2-7) unstable; urgency=medium

  * Show exception traceback in to examine ppc64el build failure.

rustc (1.17.0+dfsg2-6) unstable; urgency=medium

  * Upload to unstable.

rustc (1.17.0+dfsg2-5) experimental; urgency=medium

  * More work-arounds for armhf test failures.

rustc (1.17.0+dfsg2-4) experimental; urgency=medium

  * Fix arch-indep and arch-dep tests.
  * Bump the LLVM requirement to fix FTBFS on armhf.

rustc (1.17.0+dfsg2-3) experimental; urgency=medium

  * Try to force the real gdb package. Some resolvers like aspcud will select
    gdb-minimal under some circumstances, but this causes the debuginfo-gdb
    tests to break.

rustc (1.17.0+dfsg2-2) experimental; urgency=medium

  * Support and document cross-compiling of rustc itself.
  * Document cross-compiling other rust packages such as cargo.
  * Work around upstream #39015 by disabling those tests rather than by
    disabling optimisation, which causes FTBFS on 1.17.0 ppc64el. See
    upstream #42476 and #42532 for details.

rustc (1.17.0+dfsg2-1) experimental; urgency=medium

  [ Sylvestre Ledru ]
  * New upstream release

  [ Ximin Luo ]
  * Adapt packaging for rustbuild, the new upstream cargo-based build system.

  [ Matthijs van Otterdijk ]
  * Add a binary package, rust-src. (Closes: #846177)
  * Link to local Debian web resources in the docs, instead of remote ones.

rustc (1.16.0+dfsg1-1) unstable; urgency=medium

  * Upload to unstable so we have something to build 1.17 with.
  * Update u-ignoretest-powerpc.patch for 1.16.

rustc (1.16.0+dfsg1-1~exp2) experimental; urgency=medium

  * Don't ignore test failures on Debian unstable.
  * Re-fix ignoring armhf test, accidentally reverted in previous version.
  * Try to fix buildd failure by swapping B-D alternatives.

rustc (1.16.0+dfsg1-1~exp1) experimental; urgency=medium

  * New upstream release
  * u-ignoretest-jemalloc.patch removed (applied upstream)

  [ Matthias Klose ]
  * Bootstrap using the rustc version in the archive, on all architectures.
  * Work around a GCC 4.8 ICE on AArch64.
  * Use alternative build dependencies on cmake3 and binutils-2.26 for
    builds on 14.04 LTS (trusty).
  * debian/make_orig* Include all Ubuntu architectures.
  * debian/rules: Ignore test results for now.

rustc (1.15.1+dfsg1-1) unstable; urgency=medium

  * Upload to unstable so we have something to build 1.16 with.
  * Try to fix ignoring atomic-lock-free tests on armhf.

rustc (1.15.1+dfsg1-1~exp3) experimental; urgency=medium

  * Ignore atomic-lock-free tests on armhf.
  * Update ignoretest-armhf_03.patch for newer 1.15.1 behaviour.
  * Tidy up some other patches to do with ignoring tests.

rustc (1.15.1+dfsg1-1~exp2) experimental; urgency=medium

  * Update armhf ignoretest patch.
  * Bootstrap armhf. (Closes: #809316, #834003)
  * Bootstrap ppc4el. (Closes: #839643)
  * Fix rust-lldb symlink. (Closes: #850639)

rustc (1.15.1+dfsg1-1~exp1) experimental; urgency=medium

  * New upstream release (won't probably be in stretch).
    see the 1.4 git branch for the follow up for stable
  * Call to the test renamed from check-notidy => check
  * d/p/u-destdir-support.diff: Apply upstream patch to support
    destdir in the make install (for rustbuild, in later versions)
  * Overrides the 'binary-or-shlib-defines-rpath' lintian warnings.
    We need them for now
  * Refresh of the patches

  [ Sven Joachim ]
  * Drop Pre-Depends on multiarch-support. (Closes: #856109)

  [ Erwan Prioul ]
  * Fix test and build failures for ppc64el. (Closes: #839643)

  [ Ximin Luo ]
  * Disable rustbuild for the time being (as it was in 1.14) and instead
    bootstrap two new arches, armhf and ppc64el.
  * Switch back to debhelper 9 to make backporting easier.
  * Switch Build-Depends on binutils-multiarch back to binutils, the former is
    no longer needed by the upstream tests.

  [ Matthias Klose ]
  * Compatibility fixes and improvements to help work better on Ubuntu.

Date: 2017-07-25 11:35:13.969047+00:00
Changed-By: Chris Coulson <>
Sorry, changesfile not available.
Xenial-changes mailing list
Modify settings or unsubscribe at:

Reply via email to