Many thanks for the quick reply, and for mentioning the forum... I have to
apologize for not replying sooner - a combination of the weekend and keeping
myself busy with further testing and experimentation.

While I had browsed the mailing list archives & wiki primarily, somehow I
missed the forum completely. It looks like I could have saved some debugging
however, as after the patch, the storage functionality works fine.

Long story short: all is now working. But not to spoil everything, there are
more details below, plus one question and a minor bug report at the end.


On Sat, Jan 3, 2009 at 10:04 PM, jd <jdsw2...@yahoo.com> wrote:

>   Andrew, what version of iscsi did u have by default on Ubuntu 8.10 and
> what did u end up with after the backport. Milind, Any comments on the
> iscsiadm version problem on Ubuntu ?

Ubuntu 8.10 comes with open-iscsi 2.0.865 (where 'iscsiadm -m session'
doesn't work, as hinted to in their release notes), while my backport of
Ubuntu Jaunty's open-iscsi package is 2.0.870 (discussion here:

>   I will take a look at the log for the hang and see if I can spot
> anything. Does it happen if you wait for the summary area to be populated
> and then expand the groups and nodes ?

It happened if I was on the data center summary, group summary, or
individual server; if I allowed the initial summary to fully display or not.
I've "abandoned" my vmconsole machine for now, and installed convirt on my
laptop (also Ubuntu 8.10), where I installed convirt from package (0.8.?)
and then upgraded to 0.9.6 (src and storage folders from tar distribution,
replaced startup script) - somewhat sloppy, but it resolved the dependencies
quickly & works (help>about confirms the correct version).

I delayed pataching paramiko innitially, connected to the servers, deployed
a virtual machine based on the linux cd install image (CD is iso on nfs; hda
is an iscsi storage target), and successfully installed ubuntu using
convirt's console function. Close & start convirt, look at overall summary,
server group summary or individual summary - no freeze, although from time
to time it hangs for a few seconds. I then patched paramiko, started convirt
and it froze shortly after. Returned the original, things worked fine for a
bit, up until vmhost2 got "sticky" and froze convirt (something was up with
/proc). I put in place the patched version, and with the one server - no

Long story short, in the end it could just have been that the one vmhost of
mine which "gummed" things, even in my past trials.

Current status before migration: after cleanly rebooting the two VM hosts,
paramiko is patched, and monitoring of the status of the one provisioned is
working well.

   For the migration problem, it seems there may not be corresponding VM
> config file for the running VM (testvm2).
>  -- when the VM is running on the first node, can you do an Edit Settings
> for the VM and see config parameters ?

No. That was also part of my problems -- and I assume that whatever was not
configured  also the cause of the live migratio. However, now that I have
the environment working, I can edit without problems and live migration
worked (testvm1 from vmhost1 to vmhost2 and back).

  -- When u shutdown / kill that VM, does it disappear from the tree ?
>  You may want to select the managed server (vmhost2) and use Import config
> file(s) menu option and select the config file for the testvm2. Start the VM
> and try migration. Let us know how it goes, and we can dig further in to it.

Stopping the VM made it disappear. However, this is no longer a problem --
so surely some problem in my setup was at fault.

Regarding Linux Distros :
> -- We are currently using Fedora with KVM-70 and Cent OS 5.2 with KVM-72
> for most things. We do have Ubuntu, SLES, etc.. for testing as well.

Many thanks for the help and my apologies for bringing unconstructive
issues! At the moment, things are working well.

One question: the "Storage" summary displays as 0.00 / 16.00 GB, while
Storage is two 8GB iSCSI targets, one of which is assigned to the VM. The
question goes: how is the storage usage calculated?

As well, one bug (more esthetical than functional) to comment on: "Data
Center" summary view shows "VM Summary" as -1/1/0/0 for the "Servers" group,
while on the "Servers" group, and the individual server's, it is displayed
correctly as1/1/0/0.
I'll have to see if I can replicate the problem after my next step (which is
cleaning up the systems and starting fresh to make sure all is stable)

Hope to bring more positive comments in the future!

Check out the new SourceForge.net Marketplace.
It is the best place to buy or sell services for
just about anything Open Source.
XenMan-Users mailing list

Reply via email to