On Mon, Apr 16, 2018 at 7:04 PM, Mike Lothian <m...@fireburn.co.uk> wrote:
> Hi Mario
> Have you also tried starting a wayland Kwin session to see if Xwayland
> works? X apps don't work for me

Nope. Only KUbuntu 16.04.3 LTS + native X-Server 1.20-RC4, with all
kinds of permutations of intel-ddx/nouveau-ddx/modesetting-ddx +
dmabuf support on/off (for modesetting-ddx), nouveau-kms
atomic/non-atomic, Linux 4.17's drm-next. Didn't find any new bugs
compared to before, but didn't test AMD yet, or more modern gpu's than
my 8 year old Intel/Nvidia laptop.

With my old KDE-5 install from 16.04.3 LTS, kwin wayland is unusable,
it usually locks up at login, or locks up the whole gfx within seconds
to a few minutes of use, never survives a logout, requires reboot. I
assume this is better with recent kwin wayland, but i don't test with
it so far at all. No testing under weston + Xwayland either so far,
just wanted to get something out before going to bed.

But the bug that is fixed in this patch is so obvious, once
discovered, it could only make things work worse by "unblocking" other
so far dormant bugs :)


> Cheers
> Mike
> On Mon, 16 Apr 2018 at 07:37 Mario Kleiner <mario.kleiner...@gmail.com>
> wrote:
>> Hi again,
>> with the fresh x-server patch i just sent out, the EGL + DRI3 problems
>> under KDE are gone, at least as tested on an old Intel Ironlake and
>> GeForce Tesla.
>> I still see some more problems beyond those, which may or may not be
>> related to the new DRI3.1/3.2 stuff. On KDE-5 the KDE panel
>> occasionally freezes/becomes unresponsive, while the remaining desktop
>> continues to work. This seems to be something recent and only on
>> modesetting-ddx.
>> On intel-ddx + Ironlake i get modesetting failure at server startup,
>> but only under DRI3, and not with modesetting-ddx. The kernel drm-next
>> kernel seems to complain about unsupported tiling formats for the fb.
>> On NVidia Pascal i also saw modesetting failure, but not on older
>> Tesla gpu's.
>> This needs more testing.
>> -mario
>> On Fri, Apr 6, 2018 at 11:44 AM, Daniel Stone <dan...@fooishbar.org>
>> wrote:
>> > Hi,
>> >
>> > On 6 April 2018 at 09:48, Mike Lothian <m...@fireburn.co.uk> wrote:
>> >> Thanks for reminding me about GLX vs EGL
>> >>
>> >> The config option in KDE was removed from the System Setting app and
>> >> can
>> >> only be adjusted manually in in ~/.config/kwinrc
>> >>
>> >> GLPlatformInterface=egl
>> >>
>> >> This might explain why Daniel hasn't been seeing the issues I've been
>> >> seeing
>> >
>> > I tried this on both i915 (Skylake) and amdgpu, both of which work fine.
>> > :(
>> >
>> > KWin does seem to be extremely verbose: can you please capture the
>> > console output from it?
>> >
>> > Cheers,
>> > Daniel
xorg-devel@lists.x.org: X.Org development
Archives: http://lists.x.org/archives/xorg-devel
Info: https://lists.x.org/mailman/listinfo/xorg-devel

Reply via email to