[ 
https://issues.apache.org/jira/browse/YARN-309?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13543513#comment-13543513
 ] 

Bikas Saha commented on YARN-309:
---------------------------------

Thanks for the early patch. Overall approach looks ok. Some comments.

getNextHeartbeatInterval() or simply getHeartbeatInterval() may be better names.
nextHeartbeatInterval or simply heartbeatInterval may be better names. 

please try to adhere to existing code style (similar to 
http://portals.apache.org/development/code-standards.html) Dont use tabs. Use 2 
spaces for tabs and for indentation.

why is new exception being thrown in nodestatusUpdaterImpl?
{code}
+  private void registerWithRM() throws YarnRemoteException,IOException {
{code}

you would want to remove the existing NM-RM heartbeat config or mark is 
deprecated. heartbeatInterval can become a local variable initialized to some 
small hard-coded value.

Doesnt look like there is a need for RMTraffic. ResourceTrackerService can read 
default heartbeat interval from config during init() and then use that value.

The PBImpl changes seem incomplete since you still need to add the new field to 
the actual proto definition in yarn_server_common_protos.proto. And please look 
at existing long member values for guidance on other changes.

                
> Make RM provide heartbeat interval to NM
> ----------------------------------------
>
>                 Key: YARN-309
>                 URL: https://issues.apache.org/jira/browse/YARN-309
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Xuan Gong
>            Assignee: Xuan Gong
>         Attachments: YARN-309.1.patch
>
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to