[ 
https://issues.apache.org/jira/browse/YARN-6193?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15868359#comment-15868359
 ] 

Daniel Templeton commented on YARN-6193:
----------------------------------------

Thanks, [~kasha].  Looks like the patch needs a rebase.  Comments:

* Need javadoc on {{SchedulingPolicy.getClusterCapacity()}}.  I generally like 
to see the abstract and concrete methods grouped, but since they're already 
intermingled, I guess it's not a nit worth picking.
* Why make {{DominantResourceFairnessPolicy.COMPARATOR}} non-static?  It has no 
state.  If you're sticking with non-static, you should rename it since it's not 
a "constant" anymore.
* In {{TestFairSchedulerPreemption()}}, shouldn't this {code}    
fairsharePreemption = (mode > 0);{code} say " > 1"?

> FairScheduler might not trigger preemption when using DRF
> ---------------------------------------------------------
>
>                 Key: YARN-6193
>                 URL: https://issues.apache.org/jira/browse/YARN-6193
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: fairscheduler
>    Affects Versions: 2.8.0
>            Reporter: Karthik Kambatla
>            Assignee: Karthik Kambatla
>         Attachments: YARN-6193.000.patch
>
>
> {{FSAppAttempt#canContainerBePreempted}} verifies preempting a container 
> doesn't lead to new starvation ({{Resources.fitsIn}}). When using DRF, this 
> leads to verifying both resources instead of just the dominant resource. 
> Ideally, the check should be based on policy. 
> Note that current implementation of 
> {{DominantResourceFairnessPolicy#checkIfUsageOverFairShare}} is broken. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to