[ 
https://issues.apache.org/jira/browse/YARN-6326?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15922860#comment-15922860
 ] 

Robert Kanter commented on YARN-6326:
-------------------------------------

Seems fine overall; some minor things:
# whitespace as reported by Jenkins
# This code gets called a lot, I think we should make it a method so we can 
reduce code duplication:
{code:java}
   FSAppAttempt appAttempt = (FSAppAttempt) app.getCurrentAppAttempt();
   if (appAttempt != null) {
      return appAttempt.getFairShare().getVirtualCores();
   } else {
      return 0;
   }
{code}
# It seems funny to change the {{ResourceScheduler}} in 
{{ResourceSchedulerWrapper}} to {{AbstractYarnScheduler}}.  

> Shouldn't use AppAttemptIds to fetch applications while AM Simulator tracks 
> app in SLS
> --------------------------------------------------------------------------------------
>
>                 Key: YARN-6326
>                 URL: https://issues.apache.org/jira/browse/YARN-6326
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: scheduler-load-simulator
>            Reporter: Yufei Gu
>            Assignee: Yufei Gu
>         Attachments: YARN-6326.001.patch
>
>
> This causes a NPE issue. Beside the NPE, the metrics won't reflect the 
> different attempts. We should pass ApplicationId Instead of AppAttemptId. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to