[ 
https://issues.apache.org/jira/browse/YARN-10707?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17332739#comment-17332739
 ] 

Eric Badger commented on YARN-10707:
------------------------------------

Thanks for the updated patch, [~zhuqi]! It's much cleaner and much smaller now

{noformat}
         float nodeGpuUtilization = 0F;
+        float nodeGpus = 0F;
         try {
           if (gpuNodeResourceUpdateHandler != null) {
             nodeGpuUtilization =
                 gpuNodeResourceUpdateHandler.getNodeGpuUtilization();
+            nodeGpus =
+                gpuNodeResourceUpdateHandler.getNodePhysGpus();
           }
         } catch (Exception e) {
           LOG.error("Get Node GPU Utilization error: " + e);
         }
{noformat}
Ideally this wouldn't be GPU-specific and we could add all plugin utilizations 
to the nodeUtilization object. But that is beyond the scope of this JIRA, so I 
think this is fine. However, I think we can get a better name than 
{{nodeGpus}}. Maybe {{TotalNodeGpuUtilization}}?

Additionally, why are we sending the average GPU utilization to the NM metrics, 
but the total GPU utilization to the RM? Memory and CPU are consistent across 
the two. I don't understand why GPU is different.

> Support custom resources in ResourceUtilization, and update Node GPU 
> Utilization to use.
> ----------------------------------------------------------------------------------------
>
>                 Key: YARN-10707
>                 URL: https://issues.apache.org/jira/browse/YARN-10707
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: yarn
>            Reporter: Qi Zhu
>            Assignee: Qi Zhu
>            Priority: Major
>         Attachments: YARN-10707.001.patch, YARN-10707.002.patch, 
> YARN-10707.003.patch, YARN-10707.004.patch, YARN-10707.005.patch, 
> YARN-10707.006.patch, YARN-10707.007.patch
>
>
> Support gpu in ResourceUtilization, and update Node GPU Utilization to use 
> first.
> It will be very helpful for other use cases about GPU utilization.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to