[ 
https://issues.apache.org/jira/browse/YARN-1712?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14120890#comment-14120890
 ] 

Wangda Tan commented on YARN-1712:
----------------------------------

Hi [~subru],
Few nits,
1)
{code}
+    if (!(sched instanceof CapacityScheduler)) {
+      throw new YarnRuntimeException("Class "
+          + sched.getClass().getCanonicalName() + " not instance of "
+          + CapacityScheduler.class.getCanonicalName());
+    }
{code}
It maybe more clear to log like "CapacitySchedulerPlanFollower can only work 
with CapacityScheduler"

2) There're couple of "session" in {{synchronizePlan}}, I think it's better to 
rename them to "reservation" to make consistent, like
bq. +      int numSes = 0;
bq. +      // identify the sessions that have expired and new sessions that 
have to

One question:
In {{ReservationAllocationComparator}}
What will cause 
{code}
+      CSQueue lhsQueue = scheduler.getQueue(lhs.getReservationId().toString());
+      if (lhsQueue != null) {
+        lhsRes =
+            Resources.subtract(
+                lhs.getResourcesAtTime(now),
+                Resources.multiply(clusterResource,
+                    lhsQueue.getAbsoluteCapacity()));
+      } else {
+        lhsRes = lhs.getResourcesAtTime(now);
+      }
{code}
{{lhsQueue}} or {{rhsQueue}} become null?

Thanks,
Wangda

> Admission Control: plan follower
> --------------------------------
>
>                 Key: YARN-1712
>                 URL: https://issues.apache.org/jira/browse/YARN-1712
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: capacityscheduler, resourcemanager
>            Reporter: Carlo Curino
>            Assignee: Carlo Curino
>              Labels: reservations, scheduler
>         Attachments: YARN-1712.1.patch, YARN-1712.patch
>
>
> This JIRA tracks a thread that continuously propagates the current state of 
> an inventory subsystem to the scheduler. As the inventory subsystem store the 
> "plan" of how the resources should be subdivided, the work we propose in this 
> JIRA realizes such plan by dynamically instructing the CapacityScheduler to 
> add/remove/resize queues to follow the plan.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to