[ 
https://issues.apache.org/jira/browse/YARN-1250?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14136341#comment-14136341
 ] 

Junping Du commented on YARN-1250:
----------------------------------

bq.  We can just move "Assert.fail();" out of if block because if exception 
isn't thrown as expected, we should just get failed directly without affected 
by if case. In addition, I saw many duplicated code in tests here. Mind to 
refactor them to a common method?
Forget about this comment. Just noticed that it is a parameterized test.

> Generic history service should support application-acls
> -------------------------------------------------------
>
>                 Key: YARN-1250
>                 URL: https://issues.apache.org/jira/browse/YARN-1250
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Vinod Kumar Vavilapalli
>            Assignee: Zhijie Shen
>         Attachments: GenericHistoryACLs.pdf, YARN-1250.1.patch, 
> YARN-1250.2.patch, YARN-1250.3.patch, YARN-1250.4.patch, YARN-1250.5.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to