Vinod Kumar Vavilapalli commented on YARN-2493:

More comments:

h4. ApplicationSubmissionContext

 - Call get|setAppLabelExpression() as simply (get|set)NodeLabelExpression? 
'App' is already captured in the class-name.
 - Similarly ApplicationSubmissionContextProto.app_label_expression -> 
 - Javadoc of {get|set}AppLabelExpression() should include what it really 
means: Say "Get Node-label expression for this app. If this is set, all 
containers of this application will get allocated resources on only those nodes 
that satisfy this node-label-expression".
 - In the new constructor that you added, the priority is the AM-container 
priority while the existing constructor assumes it to be application priority. 
Let's definitely keep application-priority in all the APIs old and new.

bq. We will be supporting app-priorities via YARN-1963, let's not deprecate 
these APIs for now.
Missed this in javadoc of getPriority()? Also setPriority(Priority priority) 
was private, you made it public now.

h4. ResourceRequest

 - Call ResourceRequest.get|setLabelExpression() as 
 - Similarly ResourceRequestProto.label_expression -> node_label_expression
 - bq. Let's mark the new APIs evolving
   Missed this for this record?
 - Similar to submission context, let's put this in the javadoc: "Get Node 
Label expression for this Resource Request. If this is set, all containers 
allocated to satisfy this resource-request will be only on those nodes that 
satisfy this node-label-expression"

> [YARN-796] API changes for users
> --------------------------------
>                 Key: YARN-2493
>                 URL: https://issues.apache.org/jira/browse/YARN-2493
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: api
>            Reporter: Wangda Tan
>            Assignee: Wangda Tan
>         Attachments: YARN-2493.patch, YARN-2493.patch, YARN-2493.patch
> This JIRA includes API changes for users of YARN-796, like changes in 
> {{ResourceRequest}}, {{ApplicationSubmissionContext}}, etc. This is a common 
> part of YARN-796.

This message was sent by Atlassian JIRA

Reply via email to