Jason Lowe commented on YARN-2312:

Patch looks good overall.  Just two minor nits:

The containerId.getContainerId() & 0xffffffffffL construct shows up a number of 
times.  Wondering if there should be a utility method on ContainerId to provide 
this value or if the masking constant should be obtainable from ContainerId.

TestTaskAttemptListenerImpl.java has no changes releated to this JIRA, 
including wrapping of lines that are already less than 80 columns.  Not a 
must-fix just seemed like unnecessary extra changes.

[~jianhe] do you have any additional comments?

> Marking ContainerId#getId as deprecated
> ---------------------------------------
>                 Key: YARN-2312
>                 URL: https://issues.apache.org/jira/browse/YARN-2312
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Tsuyoshi OZAWA
>            Assignee: Tsuyoshi OZAWA
>         Attachments: YARN-2312-wip.patch, YARN-2312.1.patch, 
> YARN-2312.2-2.patch, YARN-2312.2-3.patch, YARN-2312.2.patch, 
> YARN-2312.4.patch, YARN-2312.5.patch
> {{ContainerId#getId}} will only return partial value of containerId, only 
> sequence number of container id without epoch, after YARN-2229. We should 
> mark {{ContainerId#getId}} as deprecated and use 
> {{ContainerId#getContainerId}} instead.

This message was sent by Atlassian JIRA

Reply via email to