[ 
https://issues.apache.org/jira/browse/YARN-2668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14168612#comment-14168612
 ] 

Hudson commented on YARN-2668:
------------------------------

SUCCESS: Integrated in Hadoop-Yarn-trunk #709 (See 
[https://builds.apache.org/job/Hadoop-Yarn-trunk/709/])
YARN-2668 yarn-registry JAR won't link against ZK 3.4.5. (stevel) (stevel: rev 
ac64ff77cfd87b5dd6b017468acd6698dbff43ae)
* hadoop-yarn-project/CHANGES.txt
* 
hadoop-yarn-project/hadoop-yarn/hadoop-yarn-registry/src/main/java/org/apache/hadoop/registry/client/impl/zk/RegistrySecurity.java
* 
hadoop-yarn-project/hadoop-yarn/hadoop-yarn-registry/src/test/java/org/apache/hadoop/registry/secure/TestSecureRMRegistryOperations.java
* 
hadoop-yarn-project/hadoop-yarn/hadoop-yarn-registry/src/main/java/org/apache/hadoop/registry/client/impl/zk/ZookeeperConfigOptions.java


> yarn-registry JAR won't link against ZK 3.4.5
> ---------------------------------------------
>
>                 Key: YARN-2668
>                 URL: https://issues.apache.org/jira/browse/YARN-2668
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: client
>    Affects Versions: 2.6.0
>            Reporter: Steve Loughran
>            Assignee: Steve Loughran
>             Fix For: 2.6.0
>
>         Attachments: YARN-2668-001.patch, YARN-2668-002.patch
>
>   Original Estimate: 0.5h
>  Remaining Estimate: 0.5h
>
> It's been reported that the registry code doesn't link against ZK 3.4.5 as 
> the enable/disable SASL client property isn't there, which went in with 
> ZOOKEEPER-1657.
> pulling in the constant and {{isEnabled()}} check will ensure registry 
> linkage, even though the ability for a client to disable SASL auth will be 
> lost.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to