Varun Saxena commented on YARN-3075:

bq. It is always better to have 2 methods with different arguments. 
Yeah agree that it can be more readable. Lock is anyways reentrant so can call 
getLabelsToNodes(Set<String> labels) from getLabelsToNodes(). Check for 
appropriate function to be called can be in ClientRMService.

> NodeLabelsManager implementation to retrieve label to node mapping
> ------------------------------------------------------------------
>                 Key: YARN-3075
>                 URL: https://issues.apache.org/jira/browse/YARN-3075
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>    Affects Versions: 2.7.0
>            Reporter: Varun Saxena
>            Assignee: Varun Saxena
>         Attachments: YARN-3075.001.patch, YARN-3075.002.patch

This message was sent by Atlassian JIRA

Reply via email to