[ 
https://issues.apache.org/jira/browse/YARN-3098?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14294354#comment-14294354
 ] 

Wangda Tan commented on YARN-3098:
----------------------------------

[~sunilg],
Thanks for review, 
For #1,
I didn't do that because I think add a type as parameter is not clear enough, 
since they will be used very frequently, it's more important to me to keep 
interface clean and easy (than less duplications).
Sounds reasonable? 

For #2,
Sorry I'm not quite understand your point.

Wangda

> Create common QueueCapacities class in Capacity Scheduler to track 
> capacities-by-labels of queues
> -------------------------------------------------------------------------------------------------
>
>                 Key: YARN-3098
>                 URL: https://issues.apache.org/jira/browse/YARN-3098
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: capacityscheduler
>            Reporter: Wangda Tan
>            Assignee: Wangda Tan
>         Attachments: YARN-3098.1.patch, YARN-3098.2.patch, YARN-3098.3.patch, 
> YARN-3098.4.patch
>
>
> Similar to YARN-3092, after YARN-796, now queues (ParentQueue and LeafQueue) 
> need to track capacities-label (e.g. absolute-capacity, maximum-capacity, 
> absolute-capacity, absolute-maximum-capacity, etc.). It's better to have a 
> class to encapsulate these capacities to make both better 
> maintainability/readability and fine-grained locking.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to