[ 
https://issues.apache.org/jira/browse/YARN-2799?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14321754#comment-14321754
 ] 

zhihai xu commented on YARN-2799:
---------------------------------

Hi [~djp],
Yes, you are right. that is a good catch. I uploaded a new patch 
YARN-2799.002.patch which addressed your comment.
Please review it.
thanks
zhihai

> cleanup TestLogAggregationService based on the change in YARN-90
> ----------------------------------------------------------------
>
>                 Key: YARN-2799
>                 URL: https://issues.apache.org/jira/browse/YARN-2799
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: test
>            Reporter: zhihai xu
>            Assignee: zhihai xu
>            Priority: Minor
>         Attachments: YARN-2799.000.patch, YARN-2799.001.patch, 
> YARN-2799.002.patch
>
>
> cleanup TestLogAggregationService based on the change in YARN-90.
> The following code is added to setup in YARN-90, 
> {code}
>     dispatcher = createDispatcher();
>     appEventHandler = mock(EventHandler.class);
>     dispatcher.register(ApplicationEventType.class, appEventHandler);
> {code}
> In this case, we should remove all these code from each test function to 
> avoid duplicate code.
> Same for dispatcher.stop() which is in tearDown,
> we can remove dispatcher.stop() from from each test function also because it 
> will always be called from tearDown for each test.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to