Gera Shegalov commented on YARN-2934:

Hi [~Naganarasimha]. Thanks for updating the patch. 

Things we have not addressed from my previous comments is capping the buffer 
size. But I now think it's good enough because we have a good small default for 

Still please rename:
-      FileStatus[] listStatus = fileSystem
+      FileStatus[] errorStatuses = fileSystem
or similar. It's an array of statuses and not status of a list

Let us have a space after ',' and a new line in:
-              .append(StringUtils.arrayToString(errorFileNames)).append(". ");
+              .append(StringUtils.join(", ", errorFileNames)).append(".\n");
Fix the test code accordingly

method verifyTailErrorLogOnContainerExit can/should be private. Same for 
ContainerExitHandler class.

should be 
Assume.assumeFalse(Shell.WINDOWS || Shell.OTHER);
but actually why do we need this? The test seems to be platform-independent.


seems redundant because you then have other asserts implying this already. I 
suggest to LOG.info the diagnostics instead to make the test log more useful.

> Improve handling of container's stderr 
> ---------------------------------------
>                 Key: YARN-2934
>                 URL: https://issues.apache.org/jira/browse/YARN-2934
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Gera Shegalov
>            Assignee: Naganarasimha G R
>            Priority: Critical
>         Attachments: YARN-2934.v1.001.patch, YARN-2934.v1.002.patch, 
> YARN-2934.v1.003.patch, YARN-2934.v1.004.patch, YARN-2934.v1.005.patch, 
> YARN-2934.v1.006.patch, YARN-2934.v1.007.patch, YARN-2934.v1.008.patch, 
> YARN-2934.v2.001.patch, YARN-2934.v2.002.patch, YARN-2934.v2.003.patch
> Most YARN applications redirect stderr to some file. That's why when 
> container launch fails with {{ExitCodeException}} the message is empty.

This message was sent by Atlassian JIRA

Reply via email to