[ 
https://issues.apache.org/jira/browse/YARN-4889?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15433509#comment-15433509
 ] 

Wangda Tan commented on YARN-4889:
----------------------------------

Thanks [~asuresh], some minor comments:

1) AMRMClient
- Annonate newly added constructors to @Public @Evolving (or @Unstable)? 
Suggest to use evolving to make it consistent with annotations in 
ResourceRequest
- Why previous return values of getMatchingRequests is List<Collection> but the 
newly added getMatchingRequests is Collection? Why previous return value is 
List of Collection?

2) AMRMClientImpl: 
- It’s better to make this to be INFO:
{code}
LOG.debug("No remoteRequestTable found with allocationRequestId="
 + ... )
{code}

3) Tests:
- {{testAllocRequestId}} has some duplicated logic from {{testAllocation}}, 
possible to merge them? 

> Changes in AMRMClient for identifying resource-requests explicitly
> ------------------------------------------------------------------
>
>                 Key: YARN-4889
>                 URL: https://issues.apache.org/jira/browse/YARN-4889
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: resourcemanager
>            Reporter: Subru Krishnan
>            Assignee: Arun Suresh
>         Attachments: YARN-4889.001.patch, YARN-4889.002.patch, 
> YARN-4889.003.patch
>
>
> YARN-4879 proposes the notion of identifying allocate requests explicitly.. 
> This JIRA is to track the changes in AMRMClient to keep it wire compatible 
> with the changes. Please refer to the design doc in the parent JIRA for 
> details.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to