On 17 October 2016 at 17:11, Michel D'HOOGE <michel.dho...@free.fr> wrote:

> Hi,
> From time to time I try to use the debian packages management instead of
> RPM because I feel more "at home"... And every time, there is a problem --
> but this time, I felt like I'll try to understand and solve it!
> I tried first with core-image-minimal, and it worked.
> But then I switched to core-image-sato and had the following error:
> ERROR : core-image-sato-1.0-r0 do_rootfs: Unable to install packages.
> Command '/mnt/Yocto/Fabric-x64/build/tmp/sysroots/x86_64-linux/usr/bin/apt-get
> install --force-yes --allow-unauthenticated apt packagegroup-base-extended
> packagegroup-core-ssh-dropbear dpkg packagegroup-core-x11-base
> packagegroup-core-boot packagegroup-core-x11-sato-games psplash
> packagegroup-core-x11-sato' returned 100:
> Reading package lists...
> Building dependency tree...
> Reading state information...
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created or been
> moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
> packagegroup-core-x11-base : Depends: packagegroup-core-x11-utils but it
> is not going to be installed
> E: Unable to correct problems, you have held broken packages.

I suspect this is related to meta-oe taking over some X initialization when
you add it to bblayers -- this  maybe exposes a bug in the deb packaging
implementation. In any case I can say that a deb-based core-image-sato
builds fine without meta-oe.

Note that you may have to wipe TMPDIR after bblayers changes if you're
testing this.

I have a bug on improving the X initialization mess in oe-core vs meta-oe (
https://bugzilla.yoctoproject.org/show_bug.cgi?id=5546) but please file one
on the debian packaging issue if it does not exist yet.

I checked: The package exists in /tmp/deploy/deb/all/
> packagegroup-core-x11-utils_1.0-r40_all.deb, but it is *empty*. It looks
> as if it is just there to create some RDEPENDS in the recipe.
> So... I played the game to explicitly add packages one by one to the image:
> IMAGE_INSTALL_append_pn-core-image-sato = " packagegroup-core-x11-utils
> xserver-nodm-init x11-common xserver-common"

> But now I have the following error:
> The following packages have unmet dependencies:
>  xserver-common : Conflicts: x11-common but 0.1-r47 is to be installed
xserver-common RCONFLICTS with x11-common: the package manager is doing
exactly what it was asked to do here (you shouldn't install both of those).

 - Jussi

> So my question is:
> Is using debian packages management definitely broken in Yocto? Or has
> someone managed to use it with some tweaking?
> Many thanks for your feedbacks
> Michel
> --
> _______________________________________________
> yocto mailing list
> yocto@yoctoproject.org
> https://lists.yoctoproject.org/listinfo/yocto
yocto mailing list

Reply via email to