>From: yocto-boun...@yoctoproject.org [mailto:yocto-boun...@yoctoproject.org] 
>On Behalf Of Burton, Ross
>Sent: Tuesday, March 6, 2018 12:39 PM
>To: Reyna, David L (Wind River) <david.re...@windriver.com>
>Cc: Yocto <yocto@yoctoproject.org>
>Subject: Re: [yocto] Are Windows SDKs (mingw layer) supposed to work?
>Have you tried using 2.4 to identify when it broke?  Clearly we need to extend 
>the selftest so the mingw SDK is actually tested...
>>On 6 March 2018 at 05:32, Reyna, David <david.re...@windriver.com> wrote:
>>Hi all,
>>I am trying to enable a customer for using YP SDKs on Windows. It apparently 
>>is supposed to work, but I am unable to get past fatal errors.
>>I have looked for documentation at the YP site and the meta-mingw repo, but 
>>to no avail.
>>1) My project is a simple default “qemux86-64” with YP-2.5 HEAD, with the 
>>latest “meta-mingw” layer added and <SDKMACHINE ?= "i686-mingw32">.
>>The SDK builds fine and I get the “*.xz” generated file.
>>2) However, when I use 7ZIP to extract it on my Windows host (which is 
>>recommended for XY files), I get several fatal issues.
>>  (a) I get more than a hundred errors “Can not create symbolic link: Access 
>>is denied”. 
>>While I do not care about the ones for the bin tools in the sysroot, I do 
>>care that most of the cross toolchain EXE files are thusly broken, plus many 
>>of the libraries and header files in the sysroot.
>>Am I missing a step?

Symbolic link errors could be related to the filesystem as FAT has no support 
for symbolic links. Have you tried it on an NTFS partition?

Best Regards,

yocto mailing list

Reply via email to