Hi Mark and Ross,

> Ross: Have you tried using 2.4 to identify when it broke?
I will try 2.4 and see if it is different.

> Mark: In the past 7ZIP (when not the admin) would create either copies or 
> 'shortcuts' instead of actual symbolic links.  

I will look to see if there is a new setting in 7ZIP.

> Mark: What version of windows are you using?  

I am using Windows 7.


-----Original Message-----
From: Mark Hatle [mailto:mark.ha...@windriver.com] 
Sent: Tuesday, March 06, 2018 5:40 AM
To: BURTON, ROSS; Reyna, David
Cc: Yocto; WANG, YANG
Subject: Re: Are Windows SDKs (mingw layer) supposed to work?

On 3/6/18 4:39 AM, Burton, Ross wrote:
> Have you tried using 2.4 to identify when it broke?  Clearly we need 
> to extend the selftest so the mingw SDK is actually tested...
> Ross
> On 6 March 2018 at 05:32, Reyna, David <david.re...@windriver.com 
> <mailto:david.re...@windriver.com>> wrote:
>     Hi all,____
>     __ __
>     I am trying to enable a customer for using YP SDKs on Windows. It 
> apparently
>     is supposed to work, but I am unable to get past fatal errors.____
>     __ __
>     I have looked for documentation at the YP site and the meta-mingw repo, 
> but
>     to no avail.____
>     __ __
>     1) My project is a simple default “qemux86-64” with YP-2.5 HEAD, with the
>     latest “meta-mingw” layer added and <SDKMACHINE ?= 
> "i686-mingw32">.____
>     __ __
>     The SDK builds fine and I get the “*.xz” generated file.____

The output format from the Yocto Project of a tarball has been that way since 
the beginning.  We (WR) had code that would produce a zip format, but that 
stopped working a few releases ago when the archive chaining was reworked..

We've not yet resurrected the code for the .zip generation but probably will in 
the next few months.

>     __ __
>     2) However, when I use 7ZIP to extract it on my Windows host (which is
>     recommended for XY files), I get several fatal issues.____
>     __ __
>       (a) I get more than a hundred errors “Can not create symbolic link: 
> Access
>     is denied”. ____

This is odd.  In the past 7ZIP (when not the admin) would create either copies 
or 'shortcuts' instead of actual symbolic links.  It sounds like something has 
changed in 7zip.

>     __ __
>     While I do not care about the ones for the bin tools in the sysroot, I do
>     care that most of the cross toolchain EXE files are thusly broken, plus 
> many
>     of the libraries and header files in the sysroot.____
>     __ __
>     Am I missing a step?____
>     __ __
>     If I in fact extract this file on my Linux host, I can directly see that 
> it
>     is full of symlinks! Why are there symlinks in a Windows-specific 
> tarball?____

Often I've extracted it on a linux machine, and then uses zip to recompress it.
(You still need to use 7zip to extract because of the long pathnames that blow 
up winzip.)

>     __ __
>       (b) If I attempt to build a simple C file from the shell in the SDK
>     environment, I either get a silent failure (for the 32-bit toolchain) or a
>     blatant error as per:____

What version of windows are you using?  The last time I tested this (Rocko) it 
was working properly still, but I tested with Win 7.  So it's possible that 
something more recent has broken it.

I'm not sure if I'll have time today to retry this with Rocko, but I'll see if 
I can.

yocto mailing list

Reply via email to