Toradex Qt5 complete set of layers for Colibri iMX6board (I did it in
09/2017 and implated it on Toradex development board):

This version is meta-toolchain-qt5 + angstrom-lxde-image (Qt5 + LXDE DT
with X11 server):

[user@localhost Qt5-plus-x11]$ cd oe-core
[user@localhost oe-core]$ ls -al
total 40
drwxr-----.  6 user user       4096 Oct 12  2017 .
drwxr-----.  3 user user       4096 Sep  4  2017 ..
drwxr-----.  8 user user       4096 Oct 12  2017 build
drwxr-----.  3 user vboxusers  4096 Oct 12  2017 deploy
-rwxr-----.  1 user vboxusers   674 Sep  4  2017 export
drwxr-----. 19 user vboxusers  4096 Sep  5  2017 layers
-rwxr-----.  1 user vboxusers 11923 Sep  4  2017 local.conf
drwxr-----.  7 user vboxusers  4096 Sep  4  2017 .repo
[user@localhost oe-core]$ cd layers
[user@localhost layers]$ ls -al
total 76
drwxr-----. 19 user vboxusers 4096 Sep  5  2017 .
drwxr-----.  6 user user      4096 Oct 12  2017 ..
drwxr-----. 13 user vboxusers 4096 Sep  7  2017 meta-angstrom
drwxr-----.  9 user vboxusers 4096 Sep  7  2017 meta-browser
drwxr-----. 21 user vboxusers 4096 Sep  7  2017 meta-freescale
drwxr-----.  7 user vboxusers 4096 Sep  7  2017 meta-freescale-3rdparty
drwxr-----.  6 user vboxusers 4096 Sep  7  2017 meta-freescale-distro
drwxr-----.  9 user vboxusers 4096 Sep  7  2017 meta-jetson-tk1
drwxr-----. 10 user vboxusers 4096 Sep  7  2017 meta-linaro
drwxr-----.  8 user vboxusers 4096 Sep  7  2017 meta-lxde
drwxr-----. 18 user vboxusers 4096 Sep  7  2017 meta-openembedded
drwxr-----.  6 user vboxusers 4096 Sep  7  2017 meta-qt4
drwxr-----. 11 user vboxusers 4096 Sep  7  2017 meta-qt5
drwxr-----. 10 user vboxusers 4096 Sep  7  2017 meta-snappy
drwxr-----. 13 user vboxusers 4096 Oct 12  2017 meta-toradex-bsp-common
drwxr-----. 21 user vboxusers 4096 Oct 12  2017 meta-toradex-demos
drwxr-----. 10 user vboxusers 4096 Sep  7  2017 meta-toradex-nxp
drwxr-----. 15 user vboxusers 4096 Sep  7  2017 meta-toradex-tegra
drwxr-----.  8 user vboxusers 4096 Sep  7  2017 openembedded-core









*[user@localhost layers]$ find . -name
xcb-uti*./openembedded-core/meta/recipes-graphics/xorg-lib/xcb-util_0.4.0.bb
<http://xcb-util_0.4.0.bb>./openembedded-core/meta/recipes-graphics/xorg-lib/xcb-util-renderutil_0.3.9.bb
<http://xcb-util-renderutil_0.3.9.bb>./openembedded-core/meta/recipes-graphics/xorg-lib/xcb-util-keysyms_0.4.0.bb
<http://xcb-util-keysyms_0.4.0.bb>./openembedded-core/meta/recipes-graphics/xorg-lib/xcb-util-wm_0.4.1.bb
<http://xcb-util-wm_0.4.1.bb>./openembedded-core/meta/recipes-graphics/xorg-lib/xcb-util.inc./openembedded-core/meta/recipes-graphics/xorg-lib/xcb-util-image_0.4.0.bb
<http://xcb-util-image_0.4.0.bb>./openembedded-core/meta/recipes-graphics/xorg-lib/xcb-util-image[user@localhost
layers]$ find . -name libxcb-uti*[user@localhost layers]$*

Zoran
_______

On Fri, Apr 13, 2018 at 10:17 AM, Mauro Ziliani <ma...@faresoftware.it>
wrote:

> Ok.
>
> Thanks for your help
>
>
> MZ
>
> Il 13/04/2018 09:49, Zoran Stojsavljevic ha scritto:
>
> Hello Mauro,
>
> Seems that you have somehow included duplicate recipes for xcb-util, in
> form of libxcb-util.
>
> I found the base package xcb-util in my base: meta (Open Embedded) layer:
>
> [user@localhost beaglebone-rocko-18.0.0]$ find . -name xcb-uti*
> *./meta/recipes-graphics/xorg-lib/xcb-util_0.4.0.bb
> <http://xcb-util_0.4.0.bb>*
> ./meta/recipes-graphics/xorg-lib/xcb-util-renderutil_0.3.9.bb
> ./meta/recipes-graphics/xorg-lib/xcb-util-keysyms_0.4.0.bb
> ./meta/recipes-graphics/xorg-lib/xcb-util-wm_0.4.1.bb
> ./meta/recipes-graphics/xorg-lib/xcb-util.inc
> ./meta/recipes-graphics/xorg-lib/xcb-util-image_0.4.0.bb
> ./meta/recipes-graphics/xorg-lib/xcb-util-image
> [user@localhost beaglebone-rocko-18.0.0]
>
> Since you are, after all, using imx6dl, you probably included quite a few
> more layers from Frescale/NXP, with doubled libxcb-util package included as
> well.
>
> Please, search for it there.
>
> Best Regards,
> Zoran
> _______
>
> On Fri, Apr 13, 2018 at 6:19 AM, Mauro Ziliani <ma...@faresoftware.it>
> wrote:
>
>> Hi all.
>>
>> My name's Mauro and I write from Parma, Italy.
>>
>>
>> I'm in trouble because recently I get a collision error.
>>
>> It seems that more than one recipes try to install the same file in the
>> same path in populate_sdk task
>>
>> This is an example
>>
>> --------------
>>
>> ERROR: xcb-util-0.4.0-r0 do_populate_sysroot: The recipe xcb-util is
>> trying to install files into a shared area when those files already exist.
>> Those files and their manifest location are:
>> /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-build
>> /tmp/sysroots/imx6dlsabresd/usr/lib/libxcb-util.la
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/lib/libxcb-util.so
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/lib/libxcb-util.so.1.0.0
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/lib/libxcb-util.a
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/lib/libxcb-util.so.1
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/lib/pkgconfig/xcb-event.pc
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/lib/pkgconfig/xcb-util.pc
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/lib/pkgconfig/xcb-aux.pc
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/lib/pkgconfig/xcb-atom.pc
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/include/xcb/xcb_event.h
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/include/xcb/xcb_util.h
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/include/xcb/xcb_aux.h
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/usr/include/xcb/xcb_atom.h
>>  /media/mauro/Sviluppo/CatellaniGroup/ibr115/bsp/clini5-buil
>> d/tmp/sysroots/imx6dlsabresd/sysroot-providers/xcb-util
>> --------------
>>
>>
>> I'm working with a Jethro distro
>>
>> How can I solve this problem?
>>
>>
>> Best regards,
>>
>>   MZ
>>
>> --
>> _______________________________________________
>> yocto mailing list
>> yocto@yoctoproject.org
>> https://lists.yoctoproject.org/listinfo/yocto
>>
>
>
>
-- 
_______________________________________________
yocto mailing list
yocto@yoctoproject.org
https://lists.yoctoproject.org/listinfo/yocto

Reply via email to