As described in 'How to build on Debian Sarge?', I have had some problems with zd1211 on Debian Sarge with kernel 2.6.8-2.

r52, r59, r72, and r74 cannot load because 'usb_unlock_device' and 'usb_lock_device_for_reset' are missing.

r38, r48, and r51 load, but wpa_supplicant fails to enable WPA in the driver (with wext). From reading this mailing list, I guess this is expected. Some patch for wpa_supplicant was mentioned for earlier releases, but I could not find more information.

What options do I have? Is there any way to get rid of the dependency on the two missing symbols? Otherwise, where can I find information on the wpa_supplicant patch for earlier versions? Will it works with a WPA2-PSK connection?

Or do I have to think about a kernel update? I would like to have this system as stable as possible. Can I update without leaving stable Debian? Which version of the kernel would you suggest? (I only think about this -- I do not like the idea too much.)

Thanks
Jan Henrik


-------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to