Hi all, I have a USB WLAN stick (with zd1211 chipset). 
I’m using "ZD1211LnxDrv_2_13_0_0.tar"driver for it. It is working on a PC
environment running Fedora Core 3, Linux 2.6 Kernel. 
But when I tried it on my custom platform (based on ARM) after cross
compiling, I got the following error messages after I plug-in the module and
then insmod the driver.
**********************************************************************
*******************
ZD1211B - version 2.8.0.0 
Release Ver = 4810 
zd1211:bulk out: wMaxPacketSize = 200 
zd1211:bulk in: wMaxPacketSize = 200 
zd1211:interrupt in: wMaxPacketSize = 40 
zd1211:interrupt in: int_interval = 1 
zd1211:interrupt out: wMaxPacketSize = 40 
EEPORM Ver = 4810 
zd1211:uImgLength = 1400 
zd1211:translen = 1000 
zd1211:uCodeOfst = ee00 
zd1211:result = 40 
zd1211:translen = 400 
zd1211:uCodeOfst = f600 
zd1211:result = 40 
zd1211:FIRMWARE_CONFIRM = 1 
zd1211:USB Download Boot code success 
usb 1-1: insmod timed out on ep0out usb_set_configuration() failed 
zd1211b: probe of 1-1:1.0 failed with error -5 
usbcore: registered new driver zd1211b 
usbcore: deregistering driver zd1211b 
usb 1-1: USB disconnect, address 3

*****************************************************************************************
I changed the transfer length from 4096 to 64 in function
zd1211_LoadUSBSpecCode() in zd1211.c 
Original code looks like int translen = (uImgLength > 4096)?
4096:uImgLength; 
Now i'm not getting "usb_set_configuration failed" message. But the program
control keeps on waiting at this point.......... 
*************************************************************
 wait_event(macp->regSet_wait, test_bit(ZD1211_CMD_FINISH, &macp->flags)); 
in function: 
int zd1211_USB_PACKAGE_READ_REGISTER(u16 *Address, u16 *pValue, u16
RegCount, u8 bAddUSBCSRAddress)
************************************************************* 
Callback function "zd1211_intr_cb" is not getting called and thats why bit
corresponding to "ZD1211_CMD_FINISH" in macp->flags is not getting set. 
Please respond if anybody knows this problem. 

Thanks in-advance, 
gopi. 

-- 
View this message in context: 
http://www.nabble.com/zd1211%3A--Fails-during-usb-initialization-tf1959344.html#a5374704
Sent from the zd1211-devs forum at Nabble.com.


-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys -- and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to