I've compiled r83 (and r84 from svn) on my Ubuntu 6.06 installation and
got it to work. It connects to my WLAN (even with WPA-PSK via
wpa_supplicant) but seems to be extremely slow.

Pings to my router (which is really close to it) are high and vary
heavily (rtt min/avg/max/mdev = 16.003/64.315/107.675/31.142 ms with
occasional packet loss) while it's in the range of 1ms on an other
machine. Transferring data (with Samba) goes with only a few kBps.

I'm not sure how to diagnose this, but "iwconfig wlan0" gives:
 Link Quality=100/100  Signal level=73/100  Noise level=0/100
 Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:379
 Tx excessive retries:11105  Invalid misc:0   Missed beacon:0

The "Rx invalid frag" and "Tx excessive retries" keep increassing. I've
tried playing with the rate, and other iwconfig values, without success
(probably due to my very limited wifi-knowledge). What do these
statistics mean and are they related to the slowness?

What should I do to debug the slowness? Are there other revisions I
should try (or even try zd1211rw)?

Thanks in advance for any reply,
 Bram.

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to