Hi!

First let me say sorry if there are duplicate posts, i am having trouble posting to this list and i don't know why.
My story is this. I've been trying to compile this driver ever since v.52 (noob:), but I had no luck till now. V.83 and a new slax install finaly builds the zd1221b module with no problems. I am using zd1211b cos of usb1.1 I have on my TP600. Modprobe loads it successfully and lsmod shows it loaded. And dmesg doesn't give out any suspicions there is something wrong..
But there are no interfaces.. only the local loopback.. ifconfig wlanx or ethx up doesn't work.. unknown interface: no such device

Then Ii tried to build zd1211 which builds perfectly too, even autoloads, has interfaces and I think it should connect, but the cpu usage is so high it is imposibbly to work with computer (I have 300Mhz Thinkpad)..

I tried to search for a solution in archives, but didn't find nothing.

The zd1211 gives out dmesg errors unlike the zd1211b

Hope somebody can make any sense out.

zd1211 - http://zd1211.ath.cx/ - r83
Based on www.zydas.com.tw driver version 2.5.0.0
usb 1-1: reset full speed USB device using uhci_hcd and address 2
Release Ver = 4330
zd1211:bulk out: wMaxPacketSize = 40
zd1211:bulk in: wMaxPacketSize = 40
zd1211:interrupt in: wMaxPacketSize = 40
zd1211:interrupt in: int_interval = 1
zd1211:bulk out: wMaxPacketSize = 40
EEPORM Ver = 4330
zd1211:USB Download Boot code success
zd1211:MAC address = 00:0e:2e:6c:1d:05
zd1211:AddrEntryTable = f7d4
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
zd1211:RF_Mode = 00000004
PA type: 0
AiroHa AL2230RF
zd1211:Pure B-Mode
zd1211:AllowedChannel = 000007ff
zd1211:LinkLEDn = 200
AllowedChannel = 000107ff
Region:48
zd1205: (exit) zd1205_config,
/mnt/hda2/bekap/zd1211-driver-r83/src/zd1205.c line 2601
zd1205: (exit) zd1205_init,
/mnt/hda2/bekap/zd1211-driver-r83/src/zd1205.c line 8570
usbcore: registered new driver zd1211
zd1205: (enter) zd1205_open,
/mnt/hda2/bekap/zd1211-driver-r83/src/zd1205.c line 4353
zd1205: (exit) zd1205_open,
/mnt/hda2/bekap/zd1211-driver-r83/src/zd1205.c line 4436
zd1205: (enter) zd1205_close,
/mnt/hda2/bekap/zd1211-driver-r83/src/zd1205.c line 4896
zd1211: failed rf reg_urb
zd1211:USB ST Code = -1
zd1205: (exit) zd1205_close,
/mnt/hda2/bekap/zd1211-driver-r83/src/zd1205.c line 4962

I should point out again, then when make $ ifconfig wlan0 up the
computer goes almost unresponsive due to high cpu usage or something..
i have to wait like half a minute only to see the characters i typed
into the console.

Good day to all,
Janes
-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to