I have a laptop (Medion 97900) with a built-in usb-wlan (under windows can be 
turned off by a special key).

Bus 001 Device 002: ID 0ace:1215 ZyDAS

the zd1211b-driver with kernel 2.6.17 seemed to work, but iwlist wlan0 scan is 
empty. -- any hints? I see no error messages? Does it make sense to debug the 

Following are notes on several things i tried...

ubuntu edgy 6.10:
[EMAIL PROTECTED]:~/wlan/zd1211-driver-r83$ uname -a
Linux sandra-laptop 2.6.17-10-generic #2 SMP Tue Dec 5 22:28:26 UTC 2006 i686 

after replacing zd1211rw (did not work anyhow) by zd1211b as described in 

it looked quite good...

but then i experienced frequently crashes in the keyboard driver hanging my 
machine - so i disabled it.

Also it never really worked; what i missed most was any hint of antenna 

[EMAIL PROTECTED]:~/wlan/zd1211-driver-r83$ sudo modprobe zd1211b
[EMAIL PROTECTED]:~/wlan/zd1211-driver-r83$ lsmod |grep zd
zd1211b               278636  0
usbcore               134912  6 zd1211b,usbhid,ati_remote,ohci_hcd,ehci_hcd

[EMAIL PROTECTED]:~/wlan/zd1211-driver-r83$ ifconfig
wlan0     Protokoll:Ethernet  Hardware Adresse 00:60:B3:61:EC:C0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

[EMAIL PROTECTED]:~/wlan/zd1211-driver-r83$ iwconfig
wlan0     802.11b/g NIC  ESSID:"RoSaHome"
          Mode:Managed  Frequency=2.462 GHz  Access Point: Not-Associated
          Bit Rate:1 Mb/s
          Retry:off   RTS thr=2432 B   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

[EMAIL PROTECTED]:~/wlan/zd1211-driver-r83$ iwlist wlan0 scan
wlan0     No scan results

??? Under windows an with other computers i see about 3 APs where one is mine



usb 1-1: Could not load firmware file zd1211/zd1211b_ub. Error number -2
zd1211rw 1-1:1.0: couldn't load firmware. Error number -2
usb 1-1: reset high speed USB device using ehci_hcd and address 2
zd1211rw: probe of 1-1:1.0 failed with error -2
usbcore: registered new interface driver zd1211rw

[EMAIL PROTECTED]:~$ ifconfig -a
eth0      Protokoll:UNSPEC  Hardware Adresse 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:8 dropped:8 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenl�ge:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

[EMAIL PROTECTED]:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

[EMAIL PROTECTED]:~$ lsmod|grep zd
zd1211rw               49924  0
ieee80211softmac       33792  1 zd1211rw
ieee80211              37320  2 zd1211rw,ieee80211softmac
firmware_class         14208  2 zd1211rw,pcmcia
usbcore               135812  9 

best regards,

Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier.
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to