Hi again:

I must be intensely stupid, but I still don't get it. I unistalled kernel
sources and kernel headers, searched for all files and forlders "zd1211" on
the harddrive and erased them. I then upgraded to kernel
2.5.20-8-generic(ubuntu feisty) and installed source and headers for
that kernel. Wen I then
do a search for zd_usb.c  on my harddisk there is nothing to be found. Am I
supposed to install the source packade for zd1211 too? I thought that was
the non-rw community driver, but I might be wrong.
So: Where do I find the file where I'm supposed to add my USB ID?

Best regards
Ketil Thorgersen


Message: 1
Date: Tue, 13 Feb 2007 13:17:39 +0100
From: "Ketil Thorgersen" <[EMAIL PROTECTED]>
Subject: Re: [zd1211-devs] Zd1211-devs Digest, Vol 9, Issue 5
To: zd1211-devs@lists.sourceforge.net
Message-ID:
        <[EMAIL PROTECTED]>
Content-Type: text/plain; charset="iso-8859-1"

>
>
> OK, Just a followup on this:
>
> I got it working in the actual 2.6.20 of Ubuntu Feisty. What I did:
>
> 1. Installed linux-headers-2.6.20-xxx
> 2. Installed linux-source-2.6.20
> 3. Modified the zd1211rw to add my USB ID numbers.
> 4. Compiled the module with the following:
>
> make -C /lib/modules/2.6.20-6-386/build M=`pwd` modules
>
> (standing within the directory of the 2.6.20 zd1211rw module)
>
> 5. and voil?. The new zd1211rw.ko file that appeared in the directory
> just works like a charm.
>
>        Thanks for the info!
>        diego.


Hi

This is what I am trying to do as well, but I can't resovel my problems.
Should be equally simple, but I am as I said very much a novice when it
comes to these things. I'll describe in detail my steps:
I have also installe the kernel headers, the restricted modules and the
2.6.20 source from apt get and run apt-get update - upgrade

I then downloaded the driver from yesterday unpacked it and entered that
directory.  I then tried to issu "make", but then got the previously
described errors. I also tried the command you wrote above  (except with
make -C /lib/modules/2.6.20-6-generic/build M=`pwd` modules) but that did
not work either. Could you give me a more step by step instruction please?
I
mean - such as which directory have you placed the firmware in and which
exact version of the driver do you use. I might be forced to reinstall
feisty (no problem really since I do not use it except for testing because
of the wireless issue...). How do I know where the symlink should go btw?

Sorry for bothering you guys!

Best regards
Ketil Thorgersen
-------------- next part --------------
An HTML attachment was scrubbed...

------------------------------

Message: 2
Date: Tue, 13 Feb 2007 13:22:40 +0100
From: Diego Sevilla Ruiz <[EMAIL PROTECTED]>
Subject: Re: [zd1211-devs] Zd1211-devs Digest, Vol 9, Issue 5
To: [EMAIL PROTECTED]
Cc: zd1211-devs@lists.sourceforge.net
Message-ID: <[EMAIL PROTECTED]>
Content-Type: text/plain; charset=iso-8859-15




Hi, Ketil:

        Once you have the 2.6.20 kernel source, just don't download any
other code. Just modify this one. The kernel module that comes with the
2.6.20 kernel just works out of the box, but you have to modify it to
add your corresponding USB ID numbers as explained in:

http://zd1211.ath.cx/wiki/UntestedWithRewrite

That is, once you have the 2.6.20 sources, you don't have to download
anything, just modify the zd1211rw module that this kernel brings in.

        Regards,
        diego.
-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Zd1211-devs mailing list - http://zd1211.ath.cx/
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/zd1211-devs

Reply via email to