Hi Cindy,

Tried out your example below in a vbox env, and detaching a device from a pool makes that device simply unavailable. and simply cannot be re-imported.


I then tried setting up a mirrored rpool within a vbox env, agreed one device is not USB however, when booted into the rpool, split worked, I then tried booting directly into the rpool on the faulty laptop, and split still failed.

My only conclusion for failure is
- The rpool I'm attempting to split has a LOT of history been around for some 2 years now, so has gone through a lot of upgrades etc, there may be some ZFS history there that's not letting this happen, BTW the version is 33 which is current. - or is it possible that one of the devices being a USB device is causing the failure ? I don't know.

My reason for splitting the pool was so I could attach the clean USB rpool to another laptop and simply attach the disk from the new laptop, let it resilver, installgrub to new laptop disk device and boot it up and I would be back in action.

As a workaround I'm trying to simply attach my USB rpool to the new laptop and use zfs replace to effectively replace the offline device with the new laptop disk device. So far so good, 12% resilvering, so fingers crossed this will work.

As an aside, I have noticed that on the old laptop, it would not boot if the USB part of the mirror was not attached to the laptop, successful boot could only be achieved when both mirror devices were online. Is this a know issue with ZFS ? bug ?

cheers

Matt


On 04/16/12 10:05 PM, Cindy Swearingen wrote:
Hi Matt,

I don't have a way to reproduce this issue and I don't know why
this is failing. Maybe someone else does. I know someone who
recently split a root pool running the S11 FCS release without
problems.

I'm not a fan of root pools on external USB devices.

I haven't tested these steps in a while but you might try
these steps instead. Make sure you have a recent snapshot
of your rpool on the unhealthy laptop.

1. Ensure that the existing root pool and disks are healthy.

# zpool status -x

2. Detach the USB disk.

# zpool detach rpool disk-name

3. Connect the USB disk to the new laptop.

4. Force import the pool on the USB disk.

# zpool import -f rpool rpool2

5. Device cleanup steps, something like:

Boot from media and import rpool2 as rpool.
Make sure the device info is visible.
Reset BIOS to boot from this disk.

On 04/16/12 04:12, Matt Keenan wrote:
Hi

Attempting to split a mirrored rpool and fails with error :

Unable to split rpool: pool already exists


I have a laptop with main disk mirrored to an external USB. However as
the laptop is not too healthy I'd like to split the pool into two pools
and attach the external drive to another laptop and mirror it to the new
laptop.

What I did :

- Booted laptop into an live DVD

- Import the rpool:
$ zpool import rpool

- Attempt to split :
$ zpool split rpool rpool-ext"

- Error message shown and split fails :
Unable to split rpool: pool already exists

- So I tried exporting the pool
and re-importing with a different name and I still get the same
error. There are no other zpools on the system, both zpool list and
zpool export return nothing other than the rpool I've just imported.

I'm somewhat stumped... any ideas ?

cheers

Matt
_______________________________________________
zfs-discuss mailing list
zfs-discuss@opensolaris.org
http://mail.opensolaris.org/mailman/listinfo/zfs-discuss

_______________________________________________
zfs-discuss mailing list
zfs-discuss@opensolaris.org
http://mail.opensolaris.org/mailman/listinfo/zfs-discuss

Reply via email to