> root@solaris-01:/mnt#  zpool import -d /dev/lofi
>  pool: ZP-8T-RZ1-01
>    id: 9952605666247778346
>  state: FAULTED
> status: One or more devices contains corrupted data.
> action: The pool cannot be imported due to damaged devices or data.
>   see: http://www.sun.com/msg/ZFS-8000-5E
> config:
>        ZP-8T-RZ1-01              FAULTED  corrupted data
>          raidz1-0                ONLINE
>            12339070507640025002  UNAVAIL  corrupted data
>            /dev/lofi/5           ONLINE
>            /dev/lofi/4           ONLINE
>            /dev/lofi/3           ONLINE
>            /dev/lofi/1           ONLINE

Have you also mounted the broken image as /dev/lofi/2?

When I try to recreate your situation, it looks like this (as
expected), where /dev/lofi/2 is just not present:

$ lofiadm
Block Device             File                           Options
/dev/lofi/1              /dpool/dump/temp/watched/raid1 -
/dev/lofi/3              /dpool/dump/temp/watched/raid3 -
/dev/lofi/4              /dpool/dump/temp/watched/raid4 -

$ sudo zpool import -d /dev/lofi
   pool: lpool
     id: 12540294359519404167
  state: DEGRADED
 status: One or more devices are missing from the system.
 action: The pool can be imported despite missing or damaged devices.  The
        fault tolerance of the pool may be compromised if imported.
   see: http://illumos.org/msg/ZFS-8000-2Q

        lpool            DEGRADED
          raidz1-0       DEGRADED
            /dev/lofi/1  ONLINE
            /dev/lofi/2  UNAVAIL  cannot open
            /dev/lofi/3  ONLINE
            /dev/lofi/4  ONLINE
zfs-discuss mailing list

Reply via email to