Use 'dd' to replicate as much of lofi/2 as you can onto another device, and then cable that into place?

It looks like you just need to put a functioning, working, but not correct device, in that slot so that it will import and then you can 'zpool replace' the new disk into the pool perhaps?


Gregg Wonderly

On 6/16/2012 2:02 AM, Scott Aitken wrote:
On Sat, Jun 16, 2012 at 08:54:05AM +0200, Stefan Ring wrote:
when you say remove the device, I assume you mean simply make it unavailable
for import (I can't remove it from the vdev).
Yes, that's what I meant.

root@openindiana-01:/mnt# zpool import -d /dev/lofi
??pool: ZP-8T-RZ1-01
?? ??id: 9952605666247778346
??state: FAULTED
status: One or more devices are missing from the system.
action: The pool cannot be imported. Attach the missing
?? ?? ?? ??devices and try again.
?? see: http://www.sun.com/msg/ZFS-8000-3C
config:

?? ?? ?? ??ZP-8T-RZ1-01 ?? ?? ?? ?? ?? ?? ??FAULTED ??corrupted data
?? ?? ?? ?? ??raidz1-0 ?? ?? ?? ?? ?? ?? ?? ??DEGRADED
?? ?? ?? ?? ?? ??12339070507640025002 ??UNAVAIL ??cannot open
?? ?? ?? ?? ?? ??/dev/lofi/5 ?? ?? ?? ?? ?? ONLINE
?? ?? ?? ?? ?? ??/dev/lofi/4 ?? ?? ?? ?? ?? ONLINE
?? ?? ?? ?? ?? ??/dev/lofi/3 ?? ?? ?? ?? ?? ONLINE
?? ?? ?? ?? ?? ??/dev/lofi/1 ?? ?? ?? ?? ?? ONLINE

It's interesting that even though 4 of the 5 disks are available, it still
can import it as DEGRADED.
I agree that it's "interesting". Now someone really knowledgable will
need to have a look at this. I can only imagine that somehow the
devices contain data from different points in time, and that it's too
far apart for the aggressive txg rollback that was added in PSARC
2009/479. Btw, did you try that? Try: zpool import -d /dev/lofi -FVX
ZP-8T-RZ1-01.

Hi again,

that got slightly further, but still no dice:

root@openindiana-01:/mnt#  zpool import -d /dev/lofi -FVX ZP-8T-RZ1-01
root@openindiana-01:/mnt# zpool list
NAME           SIZE  ALLOC   FREE    CAP  DEDUP  HEALTH  ALTROOT
ZP-8T-RZ1-01      -      -      -      -      -  FAULTED  -
rpool         15.9G  2.17G  13.7G    13%  1.00x  ONLINE  -
root@openindiana-01:/mnt# zpool status
   pool: ZP-8T-RZ1-01
  state: FAULTED
status: One or more devices could not be used because the label is missing
         or invalid.  There are insufficient replicas for the pool to continue
         functioning.
action: Destroy and re-create the pool from
         a backup source.
    see: http://www.sun.com/msg/ZFS-8000-5E
   scan: none requested
config:

         NAME                      STATE     READ WRITE CKSUM
         ZP-8T-RZ1-01              FAULTED      0     0     1  corrupted data
           raidz1-0                ONLINE       0     0     6
             12339070507640025002  UNAVAIL      0     0     0  was /dev/lofi/2
             /dev/lofi/5           ONLINE       0     0     0
             /dev/lofi/4           ONLINE       0     0     0
             /dev/lofi/3           ONLINE       0     0     0
             /dev/lofi/1           ONLINE       0     0     0

root@openindiana-01:/mnt# zpool scrub ZP-8T-RZ1-01
cannot scrub 'ZP-8T-RZ1-01': pool is currently unavailable

Thanks for your tenacity Stefan.
Scott
_______________________________________________
zfs-discuss mailing list
zfs-discuss@opensolaris.org
http://mail.opensolaris.org/mailman/listinfo/zfs-discuss



_______________________________________________
zfs-discuss mailing list
zfs-discuss@opensolaris.org
http://mail.opensolaris.org/mailman/listinfo/zfs-discuss

Reply via email to