Thanks for the reply.
I've just tried openindiana and it behaves identically -
disks attached to the mv88sx6081 don't show up as disks.
(and APIC error interrupt (status0=0, status1=40) is emitted at boot.)

I've tried some changes to /etc/system with no success
(sata_func_enable=0x5, ahci_msi_enabled=0, sata_max_queue_depth=1)

Is there anything else I can try?

> From: Bob Friesenhahn <>
>To: sol <> 
>Cc: "" <> 
>Sent: Wednesday, 12 December 2012, 14:49
>Subject: Re: [zfs-discuss] ZFS array on marvell88sx in Solaris 11.1
>On Wed, 12 Dec 2012, sol wrote:
>> Hello
>> I've got a ZFS box running perfectly with an 8-port SATA card
>> using the marvell88sx driver in opensolaris-2009.
>> However when I try to run Solaris-11 it won't boot.
>> If I unplug some of the hard disks it might boot
>> but then none of them show up in 'format'
>> and none of them have configured status in 'cfgadm'
>> (and there's an error or hang if I try to configure them).
>> Does anyone have any suggestions how to solve the problem?
>Since you were previously using opensolaris-2009, have you considered trying 
>OpenIndiana oi_151a7 instead?  You could experiment by booting from the live 
>CD and seeing if your disks show up.
zfs-discuss mailing list

Reply via email to