Hi all -

I'm still banging my head against this one. Update from today:

I tried creating a brand new journal in my X:\Dropbox drive (X is encrypted via 

It was editable - until I closed and re-opened.

Basically - ANY time I work with a journal in the X: drive, it almost always 
opens non-editable. If I move the files out of the X: drive (say, onto the 
desktop), then it works. Move back into X, and it doesn't work (not editable).

Bottom line: it looks like Zim + Boxcryptor + Dropbox is not really supported.

It's odd - I'm not sure why that would be. Maybe one of them keeps a file 
handle open, and Zim thinks it's read-only? I tried disabling Dropbox, and no 

Should I bother submitting a bug report? Even if this is a basically 
unsupported configuration, it might help to know about.
On 4/27/2017 8:01:31 PM, Aaron Cammarata <pouncerproducti...@yahoo.com> wrote:
Thanks Mukli - that gave me a clue on where to look next.

So, good news / bad news.

Good news, I found a workaround, and have come up with a pretty reliable 
reproduce case.

Open Zim.
BAD: Notebook1 opens, but cannot be edited. No new pages or sub-pages can be 
created, and the Notebook Editable is toggled out.
Close Zim.
Delete folder C:/Users/<username>/AppData/Local/Microsoft/Windows/INetCache/zim
Open Zim.
GOOD: Zim starts, opens the correct default notebook (Notebook1), and it is 
editable! New pages, sub pages, no problem!
Close Zim. (Note that the folder deleted above has been recreated.)
Open Zim.
BAD: the problem has returned.

So, as long as that folder exists on startup, the notebook is not editable.

The really weird thing is that I tried from the leaf nodes of that folder, to 
track down EXACTLY what file is causing the problem, and it's THAT FOLDER. Not 
the index.db, not the state.conf file, and no folder along the path between the 
deleted folder (above) and the leaf folder.

The only thing I can think of that might be odd is that the name of the folder 
with the index in it is notebook-X_Dropbox_<foldername>_<notebook name>. I 
checked, and the complete pathname is 107 characters, so even adding 10 for the 
filename should be no problem with long paths under Windows.

So, at least I have a workaround, and hopefully it will help someone pinpoint 
the problem, knowing that there's a very specific folder that causes the 

Does that jiggle any new thoughts loose?


(Other info that I don't think is relevant:
Windows 10, on an Acer Switch Alpha 12 tablet. The notebooks are in the "X" 
drive, which is a boxcryptor mount point that decrypts an encrypted folder in 
Dropbox, which is shared among multiple computers.)
On 4/26/2017 10:46:39 PM, Mukli Krisztián <krisztianmu...@mukli.hu> wrote:
I don't know why can't you edit the notebook, but you can try delete the 
AppData/Local/Temporary Internet Files/zim/zim/NOTEBOOKNAME folder 
(NOTEBOOKNAME is name of your notebook, of course). This is the real index used 
by Zim, and sometimes keep some old information, which is not updated other 
ways. After that start Zim, and use Tools/Update index menu. Maybe help, maybe 
For encryption I am experiencing encfs (now cross-platform), but I have some 
problems, because obfuscated filepath can longer than 256 chars, which is not 
supported on Windows (or not OOB), and Cryptomator, which is a very similar 
tool. I'm waiting for Cryfs, it is promising solve that problems, but it 
linux-only this time.

Mukli Krisztián
mail: krisztianmu...@mukli.hu [mailto:krisztianmu...@mukli.hu]
web: www.mukli.hu [http://www.mukli.hu]
27.04.2017 00:14 időpontban Aaron Cammarata ezt írta:
Hi all -
First off - thank you for Zim - to the authors and to everyone who's 
I use Zim on Windows 10, shared between multiple machines via Dropbox, in an 
encrypted folder managed by Boxcryptor. Yes. Yes, I realize this is wacky. What 
can I say, I don't want my journals and notebooks available unencrypted on a 
cloud service.
Anywhoo -
I have multiple notebooks, and one of them is not 'editable' on one machine.
Other notebooks are editable on this machine.
This notebook is editable on other machines.
It's only one notebook, on one machine.
Symptom: "Notebook Editable" is greyed out, as is New Page, New Sub Page, etc.
I've done a few hours of digging on the internet:
- Read only is not set
- There are no files with non-text character in the notebook folder anywhere
- The notebook is not open on any of the other machines
- I rebuild the index using the command line
- I deleted the .zim folder and rebuilt it (opened Zim again)
- I looked in the AppData/Roaming/Zim/Config files, all looks good
I'm out of ideas. Is there a log file I can see somewhere that shows why Zim 
thinks a notebook is not editable, and won't let me make it editable?

Mailing list: https://launchpad.net/~zim-wiki [https://launchpad.net/~zim-wiki]
Post to     : zim-wiki@lists.launchpad.net [mailto:zim-wiki@lists.launchpad.net]
Unsubscribe : https://launchpad.net/~zim-wiki [https://launchpad.net/~zim-wiki]
More help   : https://help.launchpad.net/ListHelp 
Mailing list: https://launchpad.net/~zim-wiki
Post to     : zim-wiki@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zim-wiki
More help   : https://help.launchpad.net/ListHelp

Reply via email to