On Wed, Feb 17, 2010 at 5:20 PM, Christian Theune <c...@gocept.com> wrote:

> On 02/17/2010 06:15 PM, Diego Acevedo wrote:
> > Hello everybody. I have a problem with zeoraid + plone (I ask for the
> > problem in the general questions in Plone, and they say me that i could
> > ask here)...
> >
> > I can do work zeoraid and plone for separate, but if I try to connect my
> > zope client instance with the zeoraid, its dont work.
> >
> > I try different configurations:
> >
> >      zope client -> zeoraid -> zeoservers;
> >      zope client -> zeoserver <- zeoraid -> zeoservers
> >      etc
> >
> > I think that the problem is the ZODB, because zeoraid (gocept.zeoraid)
> > work with ZODB3 >= 3.9, whereas Plone 3.3.4 work with Zope 2.10, and
> > this with ZODB 3.7.1...
> >
> > so, the question is, Did someone get that zeoraid and plone work
> together??
>
> The correct chain of configuration is:
>
> Zope Server -> ZEOServer with a RAIDStorage -> other backends (typically
> the second row of ZEO servers)
>
> The correct ZODB versions are:
>
> Zope Server = ZODB 3.6+
> ZEO Servers w/ and w/o ZEORAID = ZODB 3.9
>
> If you have those configurations and they don't work, then a specific
> error report would help.
>
> Christian
>
> --
> Christian Theune · c...@gocept.com
> gocept gmbh & co. kg · forsterstraße 29 · 06112 halle (saale) · germany
> http://gocept.com · tel +49 345 1229889 0 · fax +49 345 1229889 1
> Zope and Plone consulting and development
>
> _______________________________________________
> For more information about ZODB, see the ZODB Wiki:
> http://www.zope.org/Wikis/ZODB/
>
> ZODB-Dev mailing list  -  ZODB-Dev@zope.org
> https://mail.zope.org/mailman/listinfo/zodb-dev
>

Oh... nice. thank you, but now I am a little confused...

I have the next configuration right now (briefly):

ZeoRaid:

zeo1 address 8100
zeo2 address 8101
zeoraid address 8200 (and inside <raidstorage> server 8100; server 8101)

Plone (it is a zeo install, not a stand alone):

zeo-address 8100
client1 address 8080

I test starting the process in the follow orders: (for the plone client,
with /bin/client1 fg)

    client1 (plone); zeo1; zeo2; zeoraid
    client1(plone); zeo1; zeoraid; zeo2
    zeo1; client1(plone); zeo2; zeoraid
    zeo1; client1(plone); zeoraid; zeo2

Any of this is ok??, because i get the follow error when I try to modify
something in the site (zeoraid/zeo.log):

2010-02-18T11:06:35 ERROR ZEO.zrpc.Connection(S) (127.0.0.1:47827)
lastTransaction() raised exception: RAID is inconsistent and was closed.
Traceback (most recent call last):
  File
"/home/gdlk/Downloads/gocept.zeoraid-1.0b7/eggs/ZODB3-3.10.0a1-py2.5-linux-x86_64.egg/ZEO/zrpc/connection.py",
line 439, in handle_request
    ret = meth(*args)
  File
"/home/gdlk/Downloads/gocept.zeoraid-1.0b7/src/gocept/zeoraid/storage.py",
line 230, in lastTransaction
    return self._apply_all_storages('lastTransaction')
  File
"/home/gdlk/Downloads/gocept.zeoraid-1.0b7/src/gocept/zeoraid/storage.py",
line 48, in check_open
    return method(self, *args, **kw)
  File
"/home/gdlk/Downloads/gocept.zeoraid-1.0b7/src/gocept/zeoraid/storage.py",
line 852, in _apply_all_storages
    "RAID is inconsistent and was closed.")
RuntimeError: RAID is inconsistent and was closed.
------
2010-02-18T11:06:35 INFO ZEO.StorageServer (3083/127.0.0.1:47827)
disconnected


Thanks for the quickly answer of yesterday, and thanks for your time!!
_______________________________________________
For more information about ZODB, see the ZODB Wiki:
http://www.zope.org/Wikis/ZODB/

ZODB-Dev mailing list  -  ZODB-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zodb-dev

Reply via email to