I noticed my DB had swelled to 132 gigabytes (as of 3 days ago; it's 160
gigabytes today) and it seems to be because zeopack has started failing:

tsa@sp2772c:~/db$ /home/tsa/env/bin/zeopack -u /home/tsa/db/zeo.sock
Traceback (most recent call last):
  File "/home/tsa/env/lib/python2.6/site-packages/ZEO/scripts/zeopack.py",
line 159, in _main
    cs.pack(packt, wait=True)
  File "/home/tsa/env/lib/python2.6/site-packages/ZEO/ClientStorage.py",
line 916, in pack
    return self._server.pack(t, wait)
  File "/home/tsa/env/lib/python2.6/site-packages/ZEO/ServerStub.py", line
155, in pack
    self.rpc.call('pack', t, wait)
  File "/home/tsa/env/lib/python2.6/site-packages/ZEO/zrpc/connection.py",
line 730, in call
    raise inst # error raised by server
TypeError: 'NoneType' object does not support item assignment
Error:
Error packing storage 1 in '/home/tsa/db/zeo.sock'


The runzeo log is:

2013-01-07T11:29:11 INFO ZEO.StorageServer new connection :
<ManagedServerConnection >
------
2013-01-07T11:29:11 INFO ZEO.zrpc.Connection(S) () received handshake
'Z3101'
------
2013-01-07T11:29:11 INFO ZEO.StorageServer pack(time=1357576151.4019079)
started...
------
2013-01-07T11:55:37 ERROR ZEO.zrpc (8174) Error raised in delayed method
None
------
2013-01-07T11:55:37 INFO ZEO.StorageServer disconnected


The zeo.conf is:

%define INSTANCE .

<zeo>
  address $INSTANCE/zeo.sock
  read-only false
  invalidation-queue-size 100
  pid-filename $INSTANCE/zeo.pid
</zeo>

<blobstorage 1>
  <filestorage>
    path $INSTANCE/Data.fs
  </filestorage>
  blob-dir $INSTANCE/blobs
</blobstorage>


I tried shutting down the server that uses the database and re-running
zeopack, but the same thing happened.

I also tried re-starting 'runzeo' and re-running the pack (with the server
still off), and the same thing happened yet again.

How do I go about fixing this? Let me know if I can provide any other
information that would be helpful.

Thanks in advance,
- Claudiu
_______________________________________________
For more information about ZODB, see http://zodb.org/

ZODB-Dev mailing list  -  ZODB-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zodb-dev

Reply via email to